您的位置:首页 > 其它

poj1837Balance【二维01背包方法数——天平平衡】

2016-05-11 20:42 155 查看
题意

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.

It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25.
Gigel may droop any weight of any hook but he is forced to use all the weights.

Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.

It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:

• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);

• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis
(when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the
hook is attached: '-' for the left arm and '+' for the right arm);

• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4
-2 3
3 4 5 8


Sample Output

2


Source

Romania OI 2002

题意:已知砝码(都只有一个)和天平左右挂钩的位置,问有多少种使得天平平衡的方法
做法:很容易想到暴力——————是不行的,那么也容易想到dp[]下标是表示当前重量,思维定势在背包问题不用表示物品序号的那维,然后就不会写转移方程了==无耻的去翻题解,答曰需要那维表示当前物品序号,因为转移方程是dp[i][j]+=dp[i-1][j-pos[k]*weight[i]];

数组、变量把自己搞晕了QAQ 然后就是负数的处理,十分纠结于7500是中间值,要是没到这么大的话怎么办啊==看代码

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[30][20009];
int c,g,pos[30],weight[30];
int main()
{
// freopen("cin.txt","r",stdin);
// freopen("out.txt","w",stdout);
while(~scanf("%d%d",&c,&g))
{
for(int i=1;i<=c;i++)
{
scanf("%d",&pos[i]);
//cc[i]+=15;
}
for(int i=1;i<=g;i++)scanf("%d",&weight[i]);
memset(dp,0,sizeof(dp));
dp[0][10000]=1;
int maxn=20000;
for(int i=1;i<=g;i++)
for(int j=0;j<=maxn;j++)
for(int k=1;k<=c;k++)
if(j>=pos[k]*weight[i])
{
dp[i][j]+=dp[i-1][j-pos[k]*weight[i]];
//  printf("i=%d,j=%d,k=%d,dp=%d\n",i,j,k,dp[i][j]);
}

printf("%d\n",dp[g][10000]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: