您的位置:首页 > 编程语言 > C#

pat1001

2016-04-11 12:30 316 查看
Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input

-1000000 9


Sample Output

-999,991

输入两个数相加,得到的结果以千分制输出。

直接用格式化输出{#,0},后面必须要为0不能是#,不然输入0 0会没有结果

using System;

using System.Collections;

namespace Test

{

    class Program

    {

        static void Main(string[] args)

        {

            int a, b, c;

            string[] str = Console.ReadLine().Split();

            a = Convert.ToInt32(str[0]);

            b = Convert.ToInt32(str[1]);

            c = a + b;

            Console.WriteLine("{0:#,0}", c);

        }

    }

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C# PAT