您的位置:首页 > 其它

hdu 【1007】Quoit Design

2016-04-02 20:42 381 查看

Quoit Design

[b]Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 43655 Accepted Submission(s): 11351

[/b]

[align=left]Problem Description[/align]
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.

In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a
configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered
to be 0.

[align=left]Input[/align]
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates
of a toy. The input is terminated by N = 0.

[align=left]Output[/align]
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.

[align=left]Sample Input[/align]

2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0


[align=left]Sample Output[/align]

0.71
0.00
0.75


[align=left]Author[/align]
CHEN, Yue

[align=left]Source[/align]
ZJCPC2004

/*
本题利用了分治的思想,讲所有点利用x的大小进行排序,并通过x划分为2个区域,并求出2个区域中
2点之间的最小值d。因为有可能有边的2个顶点分别存在于左右2个区域,所以需要在左右2个区域筛选出
距离中点mid的x距离小于d的点,并通过y值对新组成的数组进行排序,这样可以更好地进行筛选。
需要注意的是,分治的边界是区间里面需要剩下2个点或者3个点,想一想为什么?
*/

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 100005;

struct Point
{
double x,y;
bool operator < (const Point p)const
{
return y < p.y;
}
}P[maxn];

int cmpx(Point a,Point b){
return a.x < b.x;
}

int cmpy(Point a,Point b){
return a.y < b.y;
}

int n;

double dis(Point a,Point b)
{
return sqrt((double)(a.x - b.x)*(a.x - b.x) + (double)(a.y - b.y)*(a.y - b.y));
}

double Closest(int low, int high)
{
double d1, d2, d3, d;
int mid, i, j, index;
Point S
;
if(high - low == 1)
return dis(P[low],P[high]);
if(high - low == 2)
{
d1 = dis(P[low],P[low+1]);
d2 = dis(P[low+1],P[high]);
d3 = dis(P[low],P[high]);
return min(d1,min(d2,d3));
}
mid = (low + high)/2;
d1 = Closest(low, mid);
d2 = Closest(mid+1, high);
d = min(d1,d2);
index = 0;
for(i = mid; i >= low && P[mid].x - P[i].x < d; i--)
S[index++] = P[i];
for(i = mid+1; i <= high && P[i].x - P[mid].x < d; i++)
S[index++] = P[i];
sort(S, S+index, cmpy);
for(int i = 0; i < index; i++)
{
for(int j = i+1; j < index; j++)
{
if(S[j].y - S[i].y >= d)
break;
else
{
d3 = dis(S[i], S[j]);
d = min(d, d3);
}
}
}
return d;
}

int main()
{
while(scanf("%d", &n) != EOF && n)
{
for(int i = 0; i < n; i++)
scanf("%lf%lf", &P[i].x, &P[i].y);
sort(P,P+n,cmpx);
double ans = Closest(0, n-1)/2;
printf("%.2lf\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: