您的位置:首页 > 其它

hdu【1712】ACboy needs your help

2016-03-31 20:38 295 查看

ACboy needs your help

[b]Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5878 Accepted Submission(s): 3201

[/b]

[align=left]Problem Description[/align]
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize
the profit?

[align=left]Input[/align]
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.

Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].

N = 0 and M = 0 ends the input.

[align=left]Output[/align]
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

[align=left]Sample Input[/align]

2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0


[align=left]Sample Output[/align]

3
4
6


[align=left]Source[/align]
HDU 2007-Spring Programming Contest

dd大牛的背包九讲中的分组背包问题:

P06: 分组的背包问题

问题

有N件物品和一个容量为V的背包。第i件物品的费用是c[i],价值是w[i]。这些物品被划分为若干组,每组中的物品互相冲突,最多选一件。求解将哪些物品装入背包可使这些物品的费用总和不超过背包容量,且价值总和最大。

算法

这个问题变成了每组物品有若干种策略:是选择本组的某一件,还是一件都不选。也就是说设f[k][v]表示前k组物品花费费用v能取得的最大权值,则有:

f[k][v]=max{f[k-1][v],f[k-1][v-c[i]]+w[i]|物品i属于组k}


使用一维数组的伪代码如下:

for 所有的组k

for v=V..0

for 所有的i属于组k

f[v]=max{f[v],f[v-c[i]]+w[i]}

注意这里的三层循环的顺序,甚至在本文的第一个beta版中我自己都写错了。“for v=V..0”这一层循环必须在“for 所有的i属于组k”之外。这样才能保证每一组内的物品最多只有一个会被添加到背包中。

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 105;

int dp[maxn];
int A[maxn][maxn];

int main()
{
int n,m;
while(scanf("%d%d",&n,&m) != EOF)
{
if(!n && !m) break;
for(int i = 1; i <= n; i++)
for(int j = 1; j <= m; j++)
scanf("%d",&A[i][j]);
memset(dp,0,sizeof(dp));
for(int i = 1; i <= n; i++)
for(int j = m; j >= 0; j--)
for(int k = 1; k <= m; k++)
if(j >= k) dp[j] = max(dp[j],dp[j-k] + A[i][k]);
printf("%d\n",dp[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: