您的位置:首页 > 移动开发 > IOS开发

HDU 1017:A Mathematical Curiosity【水】

2016-03-27 21:23 405 查看


A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 35317    Accepted Submission(s): 11257


Problem Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

 

Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

 

Sample Input

1

10 1
20 3
30 4
0 0

 

Sample Output

Case 1: 2
Case 2: 4
Case 3: 5注意格式;AC-code: 
#include<stdio.h>
int main()
{
int s,m,n,c;
scanf("%d",&s);
s--;
while(s--)
{
int a,b;
c=1;
while(scanf("%d%d",&n,&m),m||n)
{
int i=0;
for(a=1;a<n;a++)
for(b=a+1;b<n;b++)
if((a*a+b*b+m)%(a*b)==0)
i++;
printf("Case %d: %d\n",c++,i);
}
printf("\n");
}
int a,b;
c=1;
while(scanf("%d%d",&n,&m),m||n)
{
int i=0;
for(a=1;a<n;a++)
for(b=a+1;b<n;b++)
if((a*a+b*b+m)%(a*b)==0)
i++;
printf("Case %d: %d\n",c++,i);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: