您的位置:首页 > 编程语言 > C语言/C++

C/C++—— 输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离

2016-03-22 13:31 661 查看
Problem Description

输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。

Input

输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。

Output

对于每组输入数据,输出一行,结果保留两位小数。

Sample Input

0 0 0 1
0 1 1 0


Sample Output

1.00
1.41


考察点:浮点数输出小数点后的两位数字。循环输入(linux系统按下Ctrl+d退出while输入循环)

源代码:

#include <iostream>
#include <math.h>
#include <iomanip>

using namespace std;

int main()
{
double x1, y1, x2, y2;
double distance;

while(cin >> x1 >> y1 >> x2 >> y2){
distance = sqrt(pow(x2-x1, 2) + pow(y2-y1, 2));
cout << setprecision(2) << fixed << distance << endl;
}

return 0;
}


输出:

root@linux_ever:~/linux_ever/work_test# ./two_points_distance
0 0 0 1
1.00
0 1 1 0
1.41


题目链接:http://acm.acmcoder.com/showproblem.php?pid=2001

已提交成功:

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: