您的位置:首页 > 编程语言 > Go语言

HDU 3903 Trigonometric Function(数学定理)

2016-03-09 09:08 381 查看
Trigonometric Function

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 125536/65536 K (Java/Others)

Total Submission(s): 693 Accepted Submission(s): 277

Problem Description

Give you a triangle ABC. Get more information in the picture below.

Now, give you 6 integers a, b, c, n, m and k. a, b and c are triangle ABC`s three edges. Can you judge whether the result of the following fraction is rational number?

Input

There are several test cases in the input data.

Each case is just one line with 6 integers – a, b, c, n, m, k (0< a, b, c, n, m, k < 10^4) separated by spaces. The input data ensures that sin(kC) will not be equal with 0.

Output

Each case output “YES”, if the result of the fraction is rational number, otherwise “NO”.

Sample Input

2

1 1 1 1 1 1

3 4 5 6 7 7

Sample Output

NO

YES

若n为有理数,那么cos(n)一定是有理数

cos( k*n )一定是有理数

sin(n)确不一定。

所以只要判断分母是不是有理数就好了,sin(k*n)

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
long long int a,b,c,n,m,k;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%lld%lld%lld%lld%lld%lld",&a,&b,&c,&n,&m,&k);
long long int num=4*a*a*b*b-(a*a+b*b-c*c)*(a*a+b*b-c*c);
long long int t=sqrt(1.0*num);
if(t*t==num)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: