您的位置:首页 > Web前端 > AngularJS

ZOJ Problem Set - 2773 Triangular Sums【公式】

2016-03-01 13:42 597 查看
ZOJ Problem Set - 2773

Triangular Sums

Time Limit: 2 Seconds
Memory Limit: 65536 KB

The nth Triangular number, T(n) = 1 + ... + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side.

For example T(4):

X
X X
X X X
X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1..n; k*T(k+1)]

Input

The first line of input contains a single integer N, (1 <= N <= 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 <= n <= 300), which is the number of points on a side of the triangle.

Output

For each dataset, output on a single line the dataset number, (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum , W(n), of triangular numbers for n.

Sample Input

4

3

4

5

10

Sample Output

1 3 45

2 4 105

3 5 210

4 10 2145

Source: Greater New York Regional 2006
解题思路:
两个公式的递推。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
double oo(int i)
{
return (i*i*i+3*i*i+2*i)/2;
}
int main()
{
int T;
int y=1;
scanf("%d",&T);
while(T--)
{
int n;
scanf("%d",&n);
printf("%d %d ",y++,n);
int i,j;
double ans=0;
for(i=1;i<=n;i++)
{
ans+=oo(i);
}
printf("%.0lf\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: