您的位置:首页 > 编程语言 > Java开发

JAVA操作properties文件

2016-02-24 08:40 417 查看
Exponentiation

Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 134694 Accepted: 32951
Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
Sample Input
95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output
548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

package poj;
import java.math.BigDecimal;
import java.util.Scanner;
public class E1001_Exponentiation {
public static void main(String[] args){
Scanner in = new Scanner(System.in);
BigDecimal r;
BigDecimal result;
int n;
while(in.hasNextLine()){
r = in.nextBigDecimal();
n = in.nextInt();
result = r.pow(n);
System.out.println(result.stripTrailingZeros().toPlainString().replaceFirst("^0", ""));
}
in.close();
}
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: