您的位置:首页 > 编程语言 > Java开发

HDU1093A+B for Input-Output Practice (V)(入门题C,Java两个版本)

2016-02-23 19:38 543 查看

A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 64946 Accepted Submission(s): 43409

[align=left]Problem Description[/align]
Your task is to calculate the sum of some integers.

[align=left]Input[/align]
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

[align=left]Output[/align]
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

[align=left]Sample Input[/align]

2
4 1 2 3 4
5 1 2 3 4 5


[align=left]Sample Output[/align]

10
15


[align=left]Author[/align]
lcy

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1093

C语言AC代码:
#include <stdio.h>
int main()
{
int n,m,x,sum;
scanf("%d",&n);

while(n--)
{
scanf("%d",&m);
sum=0;
while(m--)
{
scanf("%d",&x);
sum+=x;
}
printf("%d\n",sum);
}

return 0;
}


Java AC代码:
public class Main {

public static void main(String[] args) {
Scanner sc = new Scanner(System.in);

int n = sc.nextInt();
while(n-->0){
int m = sc.nextInt();
int sum = 0;
while(m-->0){
int x = sc.nextInt();
sum += x;
}
System.out.println(sum);
}
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: