您的位置:首页 > 编程语言 > C语言/C++

[CCF]201312-1出现次数最多的数

2016-02-04 13:41 274 查看
问题描述

给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。

输出格式

输入的第一行只有一个正整数n(1<=b<=100),表示数字的个数。

输入的第二行有n个整数s1,s2,……,sn(1<=si<=10000,1<=i<=n)。相邻的数用空格分隔。

输出格式

输出这n个数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。

样例输入

6

10 1 10 20 30 20

样例输出

10

// CCF_201312-1出现次数最多的数.cpp : 定义控制台应用程序的入口点。
//

#include "stdafx.h"
#include<iostream>
using namespace std;

int _tmain(int argc, _TCHAR* argv[])
{
int n, shu, a[10000] = { 0 };
cin >> n;
for (int i = 0; i < n; i++)
{
cin >> shu;
a[shu-1]++;
}
int max = 0, maxs = 0;
for (int i = 0; i < 10000; i++)
{
if (a[i]>max)
{
max = a[i];
maxs = i + 1;
}
}
cout << maxs << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c++ ccf