您的位置:首页 > 编程语言 > Go语言

hdu3966Aragorn's Story【树链剖分+树状数组】

2016-02-02 17:10 489 查看
[align=left]Problem Description[/align]
Our protagonist is the handsome human prince Aragorn comes from The Lord of the Rings. One day Aragorn finds a lot of enemies who want to invade his kingdom. As Aragorn knows, the enemy has N camps out of his kingdom and M edges connect
them. It is guaranteed that for any two camps, there is one and only one path connect them. At first Aragorn know the number of enemies in every camp. But the enemy is cunning , they will increase or decrease the number of soldiers in camps. Every time the
enemy change the number of soldiers, they will set two camps C1 and C2. Then, for C1, C2 and all camps on the path from C1 to C2, they will increase or decrease K soldiers to these camps. Now Aragorn wants to know the number of soldiers in some particular
camps real-time.
 

[align=left]Input[/align]
Multiple test cases, process to the end of input.

For each case, The first line contains three integers N, M, P which means there will be N(1 ≤ N ≤ 50000) camps, M(M = N-1) edges and P(1 ≤ P ≤ 100000) operations. The number of camps starts from 1.

The next line contains N integers A1, A2, ...AN(0 ≤ Ai ≤ 1000), means at first in camp-i has Ai enemies.

The next M lines contains two integers u and v for each, denotes that there is an edge connects camp-u and camp-v.

The next P lines will start with a capital letter 'I', 'D' or 'Q' for each line.

'I', followed by three integers C1, C2 and K( 0≤K≤1000), which means for camp C1, C2 and all camps on the path from C1 to C2, increase K soldiers to these camps.

'D', followed by three integers C1, C2 and K( 0≤K≤1000), which means for camp C1, C2 and all camps on the path from C1 to C2, decrease K soldiers to these camps.

'Q', followed by one integer C, which is a query and means Aragorn wants to know the number of enemies in camp C at that time.

 

[align=left]Output[/align]
For each query, you need to output the actually number of enemies in the specified camp.

 

[align=left]Sample Input[/align]

3 2 5
1 2 3
2 1
2 3
I 1 3 5
Q 2
D 1 2 2
Q 1
Q 3

 

[align=left]Sample Output[/align]

7
4
8
Hint
1.The number of enemies may be negative.

2.Huge input, be careful.

 

实在是受不了邝斌那种非得用单点更新的函数写区间更新的写法,太不好理解了,自己在这个基础上改了,mark一下,以后比赛的时候要打印

一个小错误是如果初始值不加入树中,最后求再加进去的时候下标不要换成p[u]!所以说,自己写示例是多么重要

/************
hdu3966
2016.2.2
1014MS	9792K	2876 B	G++
************/
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=50005;
struct edge{
int to,next;
}edge[maxn*2];
int head[maxn],tot;
int top[maxn];//表示此节点所在重链的顶端节点
int fa[maxn];//父节点
int deep[maxn];//单纯深度,不包括点权和边权
int num[maxn];//以此节点为根的子树节点数
int p[maxn];//此点对应的位置
int fp[maxn];//与上相反
int son[maxn];//重儿子
int pos;
int c[maxn],n;
void init()
{
tot=0;
memset(head,-1,sizeof(head));
pos=1;//树状数组的
memset(son,-1,sizeof(son));
memset(c,0,sizeof(c));
}
void addedge(int u,int v)
{
edge[tot].to=v;edge[tot].next=head[u];head[u]=tot++;
}
void dfs1(int u,int pre,int d)//fa deep num son
{
deep[u]=d;
fa[u]=pre;
num[u]=1;
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].to;
if(v!=pre)
{
dfs1(v,u,d+1);
num[u]+=num[v];
if(son[u]==-1||num[v]>num[son[u]]) son[u]=v;
}
}
}
void getpos(int u,int sp)//top p
{
top[u]=sp;
p[u]=pos++;
fp[p[u]]=u;
if(son[u]==-1) return;
getpos(son[u],sp);
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].to;
if(v!=son[u]&&v!=fa[u]) getpos(v,v);
}
}
int lowbit(int x)
{
return x&(-x);
}

int sum(int i)
{
int s=0;
while(i<=n)
{
s+=c[i];
i+=lowbit(i);
}
return s;
}
void add(int i,int val)
{
while(i>0)
{
c[i]+=val;
i-=lowbit(i);
}
}
void change(int u,int v,int val)
{
int f1=top[u],f2=top[v];
while(f1!=f2)
{
if(deep[f1]<deep[f2])
{
swap(f1,f2);
swap(u,v);
}
add(p[u],val);
add(p[f1]-1,-val);
u=fa[f1];
f1=top[u];
}
if(deep[u]>deep[v]) swap(u,v);
add(p[u]-1,-val);
add(p[v],val);
}
int a[maxn];
int main()
{
// freopen("cin.txt","r",stdin);
int M,P;
while(~scanf("%d%d%d",&n,&M,&P))
{
int u,v;
int C1,C2,K;
char op[2];
init();
for(int i=1;i<=n;i++) scanf("%d",&a[i]);
while(M--)
{
scanf("%d%d",&u,&v);
addedge(u,v);addedge(v,u);
}
dfs1(1,0,0);
getpos(1,1);
while(P--)
{
scanf("%s",op);
if(op[0]=='Q')
{
scanf("%d",&u);
//  printf("sum=%d  ",sum(p[u]));
printf("%d\n",sum(p[u])+a[u]);
}
else
{
scanf("%d%d%d",&C1,&C2,&K);
if(op[0]=='D') K=-K;
change(C1,C2,K);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: