您的位置:首页 > 理论基础 > 数据结构算法

HDU1004 Let the Balloon Rise 数据结构

2016-01-31 19:20 435 查看


Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 98751    Accepted Submission(s): 37811


Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

 

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

 

Sample Output

red
pink

 
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <complex>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <cassert>
using namespace std;
#define LL long long
//#define DEBUG

int main()
{
#ifdef DEBUG
freopen("E:\\data.in", "r", stdin);
#endif // DEBUG
int n;
char now[20], maxball[20];
while (scanf("%d", &n) != EOF)
{
map<string, int>ball;
if (!n)break;
for (int i = 0; i < n; i++)
{
scanf("%s", now);
ball[now]++;
}
map<string, int>::iterator max = ball.begin();
for (map<string, int>::iterator it = ball.begin(); it != ball.end(); it++)
if (it->second > max->second)
max = it;
cout << max->first << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: