您的位置:首页 > 编程语言 > Go语言

ZOJ2855 - Google Map

2016-01-30 23:40 405 查看
题目出处:点击打开链接

Google Map

Time Limit: 2 Seconds Memory Limit: 65536 KB

GoogleMap is a useful tool and most of you should be familiar with it. As the best hacker in the world, Jack is planning to retrieve all the data on the GoogleMap server. But he soon
gives up because the total amount of data exceeds 1000T bytes! But he has learnt the way in which Google stores their data on the server, and he turns to download only the parts that he's interested in. Here is the representation of the data that Jack has
found:
First of all, you should know the basic background knowledge of GIS (Geography Information System). In GoogleMap, the whole world is represented in a whole flat image transformed from
the surface of the earth by Mercator projection. The Mercator projection is a map projection which is widely used for navigation. The following equations place the x-axis of the projection on the equator (from West to East) and the y-axis at longitude 0 (from
South to North)

x = longitude * pi / 180;
y = ln(tan(pi / 4 + (latitude * pi / 180) / 2))

Here, the latitude is between [-85, 85] (negative for South) and the longitude is between [-180, 180] (negative for West) The left of the map image is W180 and the right is E180. The
top of the map image is N85 and the bottom is S85. The maps have different levels. In the first level, the whole image consists of only one tile with tag name "t". For each tile in one level, it will be clipped into 4 equally sized parts and magnified by 2
in the next level.



And the new tag name for the tiles in the next level will be the tag of their parent tile followed by the identifier of the clip area in the parent tile. (that is, q for left-top, r for
right-top, t for left-bottom, s for right-bottom) For example:



So there will be 4L tiles in level L (Assume the first level is labeled as level 0). More interestingly, the filename of the tile on the server is just the tag name.
Although Jack is very genius, he doesn't know any programming language, so he turns to you for writing a tool to generate the tags for him.
Input
The input contains multiple test cases!
In each case, there will be three numbers. The first two are the coordinates that indicate the longitude and latitude of the interested location, and the third is the level number required
by Jack.
The longitude is between [-180, 180] (negative for West) and the latitude is between [-85, 85] (negative for South)
Output
Output the tag for the tile in the specified level that contains the location in a single line.
You can assume that the location will not be at the boundary of any tiles.
Sample Input
80 33 2

-80 -33 4

72.12 46.68 10

Sample Output
trt

ttrqt

trtrstqsrqs

Notes
You can use the 'log(double)' function to calculate the natural logarithm, and 'tan(double)' to calculate the tangent value. Both of these functions are included in the header '<math.h>'
for C or '<cmath>' for C++.

Author: FAN, Xiang

Source: Zhejiang Provincial Programming Contest 2007

先把输入点按照题目公式转换成图上的坐标点,然后用二分的思想划分四个象限

the accepted code like this:

#include<stdio.h>
#include<math.h>
#define pi acos(-1.0)
int main(){
double m,n;
int p;
while(scanf("%lf%lf%d",&m,&n,&p)!=EOF){
m=m*pi/180;
n=log(tan(pi/4+(n*pi/180)/2));
double x=-180,y=180,d=-85,t=85;
x=x*pi/180;
y=y*pi/180;
d=log(tan(pi/4+(d*pi/180)/2));
t=log(tan(pi/4+(t*pi/180)/2));
printf("t");
while(p--){
double mid1,mid2;
int flagx,flagy;
mid1=(x+y)/2;
if(m>x&&m<mid1){
flagx=0;
y=mid1;
}
else if(m>mid1&&m<y){
flagx=1;
x=mid1;
}
mid2=(d+t)/2;
if(n<t&&n>mid2){
flagy=1;
d=mid2;
}
else if(n<mid2&&n>d){
flagy=0;
t=mid2;
}
if(flagx==1&&flagy==1)
printf("r");
else if(flagx==1&&flagy==0)
printf("s");
else if(flagx==0&&flagy==1)
printf("q");
else if(flagx==0&&flagy==0)
printf("t");
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: