您的位置:首页 > 编程语言 > Go语言

hdu 3635 Dragon Balls(并查集)

2016-01-26 00:48 447 查看
问题描述

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.



His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical
strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.

Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the
ball has been transported so far.
 

输入

The first line of the input is a single positive integer T(0 < T <= 100).

For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).

Each of the following Q lines contains either a fact or a question as the follow format:

  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.

  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

 

输出

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

 

样例输入

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

 

样例输出

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int fa[10005];//根节点
int num[10005];//集合中元素的个数,num[i]表示根为i的集合的元素个数;
int nn[10005];//nn[i]记录第i个龙珠的移动次数;

int find(int a)
{
if(fa[a]==a)
return a;
else
{
int tem=fa[a];
fa[a]=find(fa[a]);
nn[a]+=nn[tem];
}
return fa[a];
}

void Union(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
{
nn[fx]++;
fa[fx]=fy;
num[fy]+=num[fx];
num[fx]=0;
}

}

int main()
{
int t;
scanf("%d",&t);
for(int k=1;k<=t;k++)
{

int n,q;
scanf("%d%d",&n,&q);
for(int i=1;i<=n;i++)
{
fa[i]=i;
num[i]=1;
nn[i]=0;
}
printf("Case %d:\n",k);
for(int i=1;i<=q;i++)
{
char tem;
int a,b;
scanf("%*c%c", &tem);
if(tem=='T')
{
scanf("%d%d",&a,&b);
Union(a,b);
}

else if(tem=='Q')
{
scanf("%d",&a);
int b=find(a);
printf("%d %d %d\n",b,num[b],nn[a]);

}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: