您的位置:首页 > 编程语言 > Go语言

poj 2007 Scrambled Polygon 【极角排序】

2015-12-23 11:48 363 查看
Scrambled Polygon

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7819 Accepted: 3719
Description

A closed polygon is a figure bounded by a finite number of line segments. The intersections of the bounding line segments are called the vertices of the polygon. When one starts at any vertex of a closed polygon and traverses each bounding line segment exactly
once, one comes back to the starting vertex. 

A closed polygon is called convex if the line segment joining any two points of the polygon lies in the polygon. Figure 1 shows a closed polygon which is convex and one which is not convex. (Informally, a closed polygon is convex if its border doesn't have
any "dents".) 



The subject of this problem is a closed convex polygon in the coordinate plane, one of whose vertices is the origin (x = 0, y = 0). Figure 2 shows an example. Such a polygon will have two properties significant for this problem. 

The first property is that the vertices of the polygon will be confined to three or fewer of the four quadrants of the coordinate plane. In the example shown in Figure 2, none of the vertices are in the second quadrant (where x < 0, y > 0). 

To describe the second property, suppose you "take a trip" around the polygon: start at (0, 0), visit all other vertices exactly once, and arrive at (0, 0). As you visit each vertex (other than (0, 0)), draw the diagonal that connects the current vertex with
(0, 0), and calculate the slope of this diagonal. Then, within each quadrant, the slopes of these diagonals will form a decreasing or increasing sequence of numbers, i.e., they will be sorted. Figure 3 illustrates this point. 


 



Input

The input lists the vertices of a closed convex polygon in the plane. The number of lines in the input will be at least three but no more than 50. Each line contains the x and y coordinates of one vertex. Each x and y coordinate is an integer in the range -999..999.
The vertex on the first line of the input file will be the origin, i.e., x = 0 and y = 0. Otherwise, the vertices may be in a scrambled order. Except for the origin, no vertex will be on the x-axis or the y-axis. No three vertices are colinear.
Output

The output lists the vertices of the given polygon, one vertex per line. Each vertex from the input appears exactly once in the output. The origin (0,0) is the vertex on the first line of the output. The order of vertices in the output will determine a trip
taken along the polygon's border, in the counterclockwise direction. The output format for each vertex is (x,y) as shown below.
Sample Input
0 0
70 -50
60 30
-30 -50
80 20
50 -60
90 -20
-30 -40
-10 -60
90 10

Sample Output
(0,0)
(-30,-40)
(-30,-50)
(-10,-60)
(50,-60)
(70,-50)
(90,-20)
(90,10)
(80,20)
(60,30)


题意:给你若干个点的坐标(x >= 0 && y >=0),第一个点是(0, 0)。现在让你按极角序逆时针输出这些点。

思路:极角排序,因为第一个点是(0, 0),所以不用找参考点了。直接排下序就好了。

G++提交用%f,C++%lf。

AC代码:

#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#define eps 1e-8
#define MAXN 100
using namespace std;
struct Point
{
double x, y;
Point(){}
Point(double X, double Y){
x = X; y = Y;
}
};
Point P[MAXN];
int dcmp(double x)
{
if(fabs(x) < eps)
return 0;
else
return x < 0 ? -1 : 1;
}
Point operator - (Point A, Point B){
return Point(A.x-B.x, A.y-B.y);
}
Point operator + (Point A, Point B){
return Point(A.x+B.x, A.y+B.y);
}
Point operator * (Point A, int p){
return Point(A.x*p, A.y*p);;
}
double Cross(Point A, Point B){
return A.x*B.y - A.y*B.x;
}
double Dot(Point A, Point B){
return A.x*B.x + A.y*B.y;
}
double Dis(Point A, Point B){
return sqrt((A.x-B.x)*(A.x-B.x) + (A.y-B.y)*(A.y-B.y));
}
bool operator == (Point A, Point B){
return dcmp(A.x-B.x) == 0 && dcmp(A.y-B.y) == 0;
}
bool cmp(Point A, Point B)//极角排序 按极角排序,若角度相等距离小的在前面
{
double temp = Cross(A-P[0], B-P[0]);
if(dcmp(temp) > 0) return true;
if(dcmp(temp) == 0 && dcmp(Dis(P[0], A) - Dis(P[0], B)) < 0) return true;
return false;
}
int main()
{
int n = 0;
while(scanf("%lf%lf", &P
.x, &P
.y) != EOF){
n++;
}
sort(P+1, P+n, cmp);//极角排序
for(int i = 0; i < n; i++)
printf("(%.0lf,%.0lf)\n", P[i].x, P[i].y);
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: