您的位置:首页 > 移动开发 > IOS开发

A Mathematical Curiosity

2015-11-28 17:09 525 查看
[align=left]Problem Description[/align]
[align=left] [/align]
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

[align=left]Input[/align]
[align=left] [/align]
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n
<= 100.

[align=left]Output[/align]
[align=left] [/align]
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

[align=left]Sample Input[/align]
[align=left] [/align]

1

10 1
20 3
30 4
0 0


[align=left]Sample Output[/align]
[align=left] [/align]
Case 1: 2

Case 2: 4

Case 3: 5

坑人的格式。。。


#include<stdio.h>
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,m,d=1;
while(scanf("%d%d",&n,&m),n||m)
{
int cnt=0;
int a,b;
printf("Case %d: ",d++);//改到崩溃了才发现,冒号与结果之间有空格,真是跪了。
for(a=1;a<n;a++)
{
for(b=a+1;b<n;b++)
{
if((a*a+b*b+m)%(a*b)==0)//整除的判断,取余为0;
cnt++;
}
}
printf("%d\n",cnt);
}
if(t)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: