您的位置:首页 > 编程语言 > Go语言

HDU_2196_Computer(树上节点的最长路径 · dfs / bfs)

2015-11-10 16:12 627 查看

Computer

[align=center]Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4723    Accepted Submission(s): 2380

[/align]

[align=left]Problem Description[/align]
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about
slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.



Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also
get S4 = 4, S5 = 4.
 

[align=left]Input[/align]
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which
i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.

 

[align=left]Output[/align]
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).

 

[align=left]Sample Input[/align]

5
1 1
2 1
3 1
1 1

 

[align=left]Sample Output[/align]

3
2
3
4
4

 
题意:求以树上每个节点为起点的最长路径。

分析:以树上最长链的两个端点为起点分别遍历整棵树,期间更新节点的最大值,这样子就可以得到每个节点的最长路径。这个是可以证明的。

所以只需要三次dfs或者bfs即可。先以任意一个点为起点,遍历整棵树,得到最长链的一个端点S,然后以此端点S遍历整棵树,得到另一个端点T,再以端点T遍历整棵树,期间更新每个节点的最大值。

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2196

代码清单:

/*******************************************************************************
*** problem ID : HDU_2194.cpp
*** create time : Mon Nov 09 23:16:46 2015
*** author name : nndxy
*** author blog : http://blog.csdn.net/jhgkjhg_ugtdk77 *** author motto: never loose enthusiasm for life, life is to keep on fighting!
*******************************************************************************/

#include <map>
#include <set>
#include <cmath>
#include <queue>
#include <stack>
#include <ctime>
#include <vector>
#include <cctype>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <bits/stdc++.h>

using namespace std;

#define exit() return 0

typedef long long ll;
typedef unsigned int uint;
typedef unsigned long long ull;

const int maxn = 10000 + 5;

struct Edge{
int to;
int dis;
Edge() {}
Edge(int _to, int _dis) : to(_to), dis(_dis) {}
};

int n, a, b;
vector <Edge> graph[maxn];
int dist[maxn];

void init(){
for(int i = 1; i <= n; i++){
graph[i].clear();
dist[i] = -1;
}
}

void input(){
for(int i = 2; i <= n; i++){
scanf("%d%d", &a, &b);
graph[i].push_back(Edge(a, b));
graph[a].push_back(Edge(i, b));

}
}

int bfs(int s){
bool vis[maxn];
memset(vis, false, sizeof(vis));
queue <Edge> q;
while(!q.empty()) q.pop();
q.push(Edge(s, 0));
vis[s] = true;
int maxd = 0, idx = s;
while(!q.empty()){
Edge p = q.front(); q.pop();
dist[p.to] = max(dist[p.to], p.dis);
if(dist[p.to] > maxd) { maxd = dist[p.to]; idx = p.to; }
for(int i = 0; i < graph[p.to].size(); i++){
Edge& e = graph[p.to][i];
if(!vis[e.to]){
vis[e.to] = true;
q.push(Edge(e.to, p.dis + e.dis));
}
}
}
return idx;
}

int max_len, id;
void dfs(int u, int fa, int len){
if(len > max_len){ max_len = len; id = u; }
dist[u] = max(dist[u], len);
for(int i = 0; i < graph[u].size(); i++){
int v = graph[u][i].to;
if(v == fa) continue;
dfs(v, u, len + graph[u][i].dis);
}
}

void bfs_work(){
int ss = 1;
ss = bfs(ss);
ss = bfs(ss);
ss = bfs(ss);
}

void dfs_work(){
max_len = -1;
dfs(1, -1, 0);
dfs(id, -1, 0);
dfs(id, -1, 0);
}

void solve(){
dfs_work();
for(int i = 1; i <= n; i++){
printf("%d\n", dist[i]);
}
}

int main(){
while(scanf("%d", &n) != EOF){
init();
input();
solve();
} exit();
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm algorithm HDU dfs tree