您的位置:首页 > 编程语言 > Go语言

POJ 2262 Goldbach's Conjecture

2015-11-09 22:39 393 查看

Goldbach's Conjecture

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41506 Accepted: 15899
Description
In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:

Every even number greater than 4 can be

written as the sum of two odd prime numbers.

For example:
8 = 3 + 5. Both 3 and 5 are odd prime numbers.

20 = 3 + 17 = 7 + 13.

42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)

Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

Input
The input will contain one or more test cases.

Each test case consists of one even integer n with 6 <= n < 1000000.

Input will be terminated by a value of 0 for n.
Output
For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes
adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input
8
20
42
0

Sample Output
8 = 3 + 5
20 = 3 + 17
42 = 5 + 37


//:poj2262 Goldbach's Conjecture
//import java.math.*;
import java.util.Scanner;
public class poj2262 {
public static void main(String[] args)
{
final int n=1000010;
int i,j;
int[] num=new int
;
for(i=0;i<n;i++)
num[i]=0;
for(i=2;i<=Math.sqrt(n);i++)
for(j=i+i;j<n;j+=i)
if(num[j]==0)
num[j]=1;

//		for(i=0;i<50;i++)
//		System.out.printf("%d %d\n",i,num[i]);
int m;
boolean judge;
Scanner input=new Scanner(System.in);
while(true)
{
m=input.nextInt();
if(m==0) break;
for(i=2,judge=false;i<=m/2;i++)
if(num[i]==0&&num[m-i]==0)
{
judge=true;
break;
}

if(judge==true)
System.out.printf("%d = %d + %d\n",m,i,m-i);
else
System.out.printf("Goldbach's conjecture is wrong.\n");
}
input.close();
}
}
///:~
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: