您的位置:首页 > 编程语言 > Go语言

HDU 4355 (三分算法基础)

2015-11-07 19:09 375 查看


Party All the Time

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4553    Accepted Submission(s): 1419


Problem Description

In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long
way.According to our observation,a spirit weighing W will increase its unhappyness for S3*W units if it walks a distance of S kilometers. 

Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.

 

Input

The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x[i]<=x[i+1] for
all i(1<=i<N). The i-th line contains two real number : Xi,Wi, representing the location and the weight of the i-th spirit. ( |xi|<=106, 0<wi<15 )

 

Output

For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.

 

Sample Input

1
4
0.6 5
3.9 10
5.1 7
8.4 10

 

Sample Output

Case #1: 832

 

题解:简单想想就能知道答案应该在MIN(X[I])和MAX(X[I])之间,而且这个函数应该是一个明显的凹函数。然后就是一个明显的三分算法了~

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#define eps 1e-6
using namespace std;

const int maxx = 50000 + 10;
int T;
int N;
double x[maxx];
double s[maxx];
double kmin,kmax;

double cal(double xx)
{
double kans = 0;
for(int i = 0;i < N; ++i){
kans += fabs((x[i]-xx)*(x[i]-xx)*(x[i]-xx)*s[i]);
}
return kans;
}

double solve()
{
double L, R;
double mid, midmid;
L = kmin; R = kmax;
while (L + eps <= R)
{
mid = (L + R)/2.0;
midmid = (mid + R)/2.0;
if (cal(mid)<=cal(midmid)) R = midmid;
else L = mid;
}
return cal(L);
}

int main( ){
cin>>T;
int kcount = 1;
while(T--){
scanf("%d",&N);
kmin = 1e8;
kmax = -kmin;
for(int i = 0;i < N; ++i){
scanf("%lf%lf",&x[i],&s[i]);
kmin = min(x[i],kmin);
kmax = max(x[i],kmax);
}
double ans = solve();
printf("Case #%d: %I64d\n",kcount++,(long long)(ans+0.5));
}
return 0;
}


如有BUG,请大家务必指出,不胜感激~

E-mail:274489985@qq.com
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息