您的位置:首页 > 编程语言 > Java开发

PAT 1019. General Palindromic Number (20)

2015-11-01 18:57 661 查看


1019. General Palindromic Number (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1
digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is
non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated
by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0".
Notice that there must be no extra space at the end of output.
Sample Input 1:
27 2

Sample Output 1:
Yes
1 1 0 1 1

Sample Input 2:
121 5

Sample Output 2:
No
4 4 1
题目解析:
本题要做的是算出题目给的数在某基数下的值是否是回文。
要做的就是:1)进制转换;2)判断是否回文。
考察重点:
进制转换

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int N, D;
N = scanner.nextInt();
D = scanner.nextInt();
scanner.close();
List<Integer> result = getNumInRadix(N, D);

if (IsPalindromic(result)) {
System.out.println("Yes");
} else
System.out.println("No");
ReverseOutput(result);
}

static List<Integer> getNumInRadix(int N, int D) {
List<Integer> result = new ArrayList<Integer>();
do {
result.add(N % D);
N /= D;
} while (N != 0);
return result;
}

static boolean IsPalindromic(List<Integer> list) {
int len = list.size();
for (int i = 0; i < len; ++i) {
if (list.get(i) != list.get(len - 1 - i))
return false;
}
return true;
}

static void ReverseOutput(List<Integer> list) {
int len = list.size();
for (int i = len - 1; i >= 0; --i) {
if (i != 0)
System.out.print(list.get(i) + " ");
else
System.out.println(list.get(i));
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT java