您的位置:首页 > 编程语言 > Go语言

POJ 2262 Goldbach's Conjecture(素数表分解质数)

2015-10-18 17:53 465 查看
Goldbach's Conjecture

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41314 Accepted: 15827
Description
In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:

Every even number greater than 4 can be

written as the sum of two odd prime numbers.

For example:
8 = 3 + 5. Both 3 and 5 are odd prime numbers.

20 = 3 + 17 = 7 + 13.

42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)

Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

Input
The input will contain one or more test cases.

Each test case consists of one even integer n with 6 <= n < 1000000.

Input will be terminated by a value of 0 for n.
Output
For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes
adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input
8
20
42
0

Sample Output
8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

将一个数分解为两个素数相加,且差值最大的那一个,因为数据范围为100w,所以直接打一个素数表就行了。

ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 1000100
#define INF 0xfffffff
#define MIN(a,b) a>b?b:a
using namespace std;
int v[MAXN];
void db()
{
int i,j;
memset(v,0,sizeof(v));
for(i=2;i<=1000000;i++)
{
if(v[i]==0)
{
for(j=i*2;j<=1000000;j+=i)
v[j]=1;
}
}
}
int main()
{
db();
int num;
int i;
while(scanf("%d",&num)&&num)
{
int bz=0;
for(i=2;i<num;i++)
{
if(!v[i]&&!v[num-i])
{
printf("%d = %d + %d\n",num,i,num-i);
bz=1;
break;
}
}
if(bz==0)
printf("Goldbach's conjecture is wrong.\n");
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: