您的位置:首页 > 编程语言 > Java开发

HDU1034 Candy Sharing Game(java)

2015-10-16 09:28 155 查看
Problem Description

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.

Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input

The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.

Output

For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input

6

36

2

2

2

2

2

11

22

20

18

16

14

12

10

8

6

4

2

4

2

4

6

8

0

Sample Output

15 14

17 22

4 8

candy是先给别人,再从别人那获得。

import java.util.Scanner;

public class P1034 {

public static void main(String[] args) {
new P1034().run();
}

public void run() {
Scanner scanner = new Scanner(System.in);
int n;
int[] peop;
int i, res;
while ((n = scanner.nextInt()) != 0) {
peop = new int
;
res = 0;
for (i = 0; i < n; i++) {
peop[i] = scanner.nextInt();
}
while (true) {
for (i = 1; i < n; i++) {
if (peop[0] != peop[i])
break;
}
if (i >= n)
break;
res++;
int temp = peop[n - 1] / 2;
for (i = n - 1; i > 0; i--) {
peop[i] = peop[i - 1] / 2 + peop[i] / 2;;
}
peop[0] = temp + peop[0] / 2;
for (i = 0; i < n; i++) {
if ( (peop[i]&1) != 0)
peop[i]++;
}
}
System.out.println(res +" "+peop[0]);
}
scanner.close();
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: