您的位置:首页 > 编程语言 > C语言/C++

PAT(1004) 成绩排名(20)

2015-09-17 09:39 399 查看
读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为

第1行:正整数n
第2行:第1个学生的姓名 学号 成绩
第3行:第2个学生的姓名 学号 成绩
... ... ...
第n+1行:第n个学生的姓名 学号 成绩

其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:
Mike CS991301
Joe Math990112
 
解题思路:其实只需要两个vector<string> ,两个int存放最大最小下标就可以了,但是我把它复杂化,首次使用面向对象的思想,值得纪念下,嘿嘿。#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;

class student
{
public:
student();
student(const string names, const string nums, const int sco) :name(names),number(nums),score(sco) {}
inline void print(){ cout << name << " " << number << endl; }
friend bool Compare(const student& stu1, const student& stu2);
private:
string name;
string number;
int score;
};

bool Compare(const student& stu1, const student& stu2)
{
return stu1.score < stu2.score;
}

int main()
{
vector<student> vstudent;
int count = 0;
string name;
string number;
int score;
cin >> count;
while (count--)
{
cin >> name >> number >> score;
student stu(name, number, score);
vstudent.push_back(stu);
}

sort(vstudent.begin(), vstudent.end(), Compare);

(--(vstudent.end()))->print();
(vstudent.begin())->print();

system("pause");
return 0;
}
 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息