您的位置:首页 > 理论基础 > 计算机网络

Elven Postman【HDU 5444】【长春网络赛】

2015-09-15 20:41 525 查看
Problem Description

Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs
through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully
like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having
the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it
encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.



题意:一个快递员送快递,每次都是从第一个要送达快递的地方开始,记录并输出每次送达目的地所需要向W转还是

E转的路径情况。

思路:建立一个平衡二叉树,然后中序遍历输出结果。

Input

First you are given an integer T(T≤10) indicating
the number of test cases.

For each test case, there is a number n(n≤1000) on
a line representing the number of rooms in this tree. n integers
representing the sequence written at the root follow, respectively a1,...,an where a1,...,an∈{1,...,n}.

On the next line, there is a number q representing
the number of mails to be sent. After that, there will be q integers x1,...,xq indicating
the destination room number of each mail.

Output

For each query, output a sequence of move (E or W)
the postman needs to make to deliver the mail. For that E means
that the postman should move up the eastern branch and W the
western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.

Sample Input

2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1


Sample Output

E

WE
EEEEE


<span style="font-size:18px;">#include <iostream>
#include <cstdio>
using namespace std;
struct node
{
int data;
node *w,*e;
}*root;

node *vis[1010];                   //记录每次申请新空间的地址以便后边释放所用的空间
int cnt;

void destroy()                        //释放所用空间
{
for(int i=0; i<cnt; i++)
{
node *p=vis[i];
delete p;
}
}

void init()                              //初始化申请一个空节点当作根
{
root=new node;
root->data=-1;
root->w=root->e=NULL;
cnt=0;
}

void add(int x)                        //往树中插数建立平衡树
{
node *p,*q;
p=root;
q=p->w;
//    printf("x = %d\n",x);
while(q)
{
p=q;
if(x>q->data)
q=q->w;
else
q=q->e;
}
q=new node;
vis[cnt++]=q;
q->w=q->e=NULL;
q->data=x;
if(x>p->data)
p->w=q;
else
p->e=q;
//        printf("%d\n",q->data);
}

void query(int x)                          //在树中查找所需元素
{
node *p=root->w;
while(p->data!=x)
{
if(x>p->data)
{
printf("W");
p=p->w;
}
else
{
printf("E");
p=p->e;
}
}
printf("\n");
}

int main()
{

int T;
scanf("%d",&T);
while(T--)
{
init();
int n,x;
scanf("%d",&n);
for(int i=1; i<=n; i++)
{
scanf("%d",&x);
add(x);
}
int q;
scanf("%d",&q);
while(q--)
{
scanf("%d",&x);
query(x);
}
destroy();
}
return 0;
}
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: