您的位置:首页 > 理论基础 > 计算机网络

2015 ACM ICPC 长春赛区 网络赛 HDU 5437 Alisha’s Party

2015-09-14 11:07 483 查看

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 980    Accepted Submission(s): 266


[align=left]Problem Description[/align]
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough,
Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every
friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n−th person to enter her castle is.

The first line of the input gives the number of test cases, T , where 1≤T≤15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000. The door would open m times before all Alisha’s friends arrive where 0≤m≤k. Alisha will have q queries where 1≤q≤100.

The i−th of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1≤vi≤108, separated by a blank. Bi is the name of the i−th person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t−th person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1−th,...,nq−th friends to enter her castle.

Note: there will be at most two test cases containing n>10000.

 

[align=left]Output[/align]
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

[align=left]Sample Input[/align]

1
5 2 3
Sorey 3
Rose 3
Maltran 3
Lailah 5
Mikleo 6
1 1
4 2
1 2 3

 

[align=left]Sample Output[/align]

Sorey Lailah Rose

 

[align=left]Source[/align]
2015 ACM/ICPC Asia Regional Changchun Online 

题意:有k个人,每个人拿着礼物,按照礼物的贵重以及时间的先后进门,而门只在特定的时间打开放进特定的人数,最后所有人都会进门,询问进门的顺序。

既然是排队问题的模拟,那么队列是跑不了了,再加上礼物贵重的先来的先进,那么可以考虑优先队列,按照礼物的贵重以及时间进行重载小于号,每次队列中增加一个人,到大开门时间就从队列中出人。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
#define MAX 150010
using namespace std;

struct Friend
{
char name[210];
int value,time;
friend bool operator<(Friend a,Friend b)//使用优先队列需要重载小于号
{
if(a.value==b.value)
return a.time>b.time;
return a.value<b.value;
}
};

struct Open//保存开门的时间及所进人数
{
int t,p;
};

Friend friends[MAX];//存放初始的顺序
Open open[MAX];//存放开门的顺序
int ask[110];//存放查询的值
int get_in[MAX];//存放所有进门的顺序

bool cmp(const Open& a,const Open& b)//比较函数
{
if(a.t<b.t)
return true;
else
return false;
}

int main()
{
int t;
int k,m,q;
int i,j;
int open_count,get_in_count;
scanf("%d",&t);
while(t--)
{
get_in_count=open_count=0;//初始化
scanf("%d%d%d",&k,&m,&q);
for(i=0;i<k;i++)//输入人名及礼物
{
scanf("%s%d",friends[i].name,&friends[i].value);
friends[i].time=i;
}
open[0].t=-1;//重要!要考虑m为0的情况,即只开了一次门
for(i=0;i<m;i++)//输入开门顺序
{
scanf("%d%d",&open[i].t,&open[i].p);
}
sort(open,open+m,cmp);//重要!所给开门顺序不一定是按时间排序的
for(i=0;i<q;i++)
{
scanf("%d",&ask[i]);
ask[i]--;
}
priority_queue<Friend> que;//优先队列,按照礼物及时间排序
for(i=0;i<k;i++)
{
que.push(friends[i]);//来了一个好友
if((i+1)==open[open_count].t)//如果正好是开门的时间
{
for(j=0;j<open[open_count].p&&(!que.empty());j++)//最多放进p个人
{
Friend frd=que.top();
que.pop();
get_in[get_in_count++]=frd.time;//加入进门顺序
}
open_count++;
}
}
while(!que.empty())//剩下的人全部进入
{
Friend frd=que.top();
que.pop();
get_in[get_in_count++]=frd.time;
}
for(i=0;i<q;i++)//输出
{
printf("%s%c",friends[get_in[ask[i]]].name,i==q-1?'\n':' ');
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息