您的位置:首页 > 理论基础 > 计算机网络

2015长春网络赛1001 - HDU5433 - Alisha’s Party (模拟)

2015-09-13 18:08 691 查看


Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 0 Accepted Submission(s): 0



Problem Description

Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v,
and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people
enter her castle. If there are less than p people
in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please
tell Alisha who the n−th person
to enter her castle is.

Input

The first line of the input gives the number of test cases, T ,
where 1≤T≤15.

In each test case, the first line contains three numbers k,m and q separated
by blanks. k is
the number of her friends invited where 1≤k≤150,000.
The door would open m times before all Alisha’s friends arrive where 0≤m≤k.
Alisha will have q queries
where 1≤q≤100.

The i−th of
the following k lines
gives a string Bi,
which consists of no more than 200 English
characters, and an integer vi, 1≤vi≤108,
separated by a blank. Bi is
the name of the i−th person
coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines
contains two integers t(1≤t≤k) and p(0≤p≤k) separated
by a blank. The door will open right after the t−th person
arrives, and Alisha will let p friends
enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated
by a space, which means Alisha wants to know who are the n1−th,...,nq−thfriends
to enter her castle.

Note: there will be at most two test cases containing n>10000.

Output

For each test case, output the corresponding name of Alisha’s query, separated by a space.

Sample Input

1
5 2 3
Sorey 3
Rose 3
Maltran  3
Lailah 5
Mikleo  6
1 1
4 2
1 2 3


Sample Output

Sorey Lailah Rose
#include <map>
#include <set>
#include <cmath>
#include <ctime>
#include <queue>
#include <vector>
#include <cctype>
#include <cstdio>
#include <string>
#include <cstring>
#include <sstream>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <functional>
using namespace std;

#define pb push_back
#define mp make_pair
#define fillchar(a, x) memset(a, x, sizeof(a))
#define copy(a, b) memcpy(a, b, sizeof(a))

typedef long long LL;
typedef pair<int, int > PII;
typedef unsigned long long uLL;
template<typename T>
void print(T* p, T* q, string Gap = " ") {
int d = p < q ? 1 : -1;
while(p != q) {
cout << *p;
p += d;
if(p != q) cout << Gap;
}
cout << endl;
}
template<typename T>
void print(const T &a, string bes = "") {
int len = bes.length();
if(len >= 2)cout << bes[0] << a << bes[1] << endl;
else cout << a << endl;
}

const int INF = 0x3f3f3f3f;
const int MAXM = 2e5;
const int MAXN = 50 + 5;

int T, k, m, q;
struct F {
int v, id;
string name;
bool operator < (const F & a) const {
if(v == a.v) return id > a.id;
return v < a.v;
}
} fs[MAXM];

struct O {
int t, p;
bool operator < (const O & a)const {
return t < a.t;
}
} os[MAXM];

string Name[MAXM];
char word[300 + 5];

int main() {
scanf("%d", &T);
while(T --) {
scanf("%d %d %d", &k, &m, & q);
for(int i = 1; i <= k; i ++) {
scanf("%s %d", word, &fs[i].v);
fs[i].name = string(word);
fs[i].id = i;
}
for(int i = 1; i <= m; i ++) {
scanf("%d %d", &os[i].t, &os[i].p);
}
sort(os + 1, os + m + 1);
int cnt = 1, ans = 1;
priority_queue<F>que;
for(int i = 1; i <= m; i ++) {
while(cnt <= os[i].t) que.push(fs[cnt ++]);
for(int j = 0; j < os[i].p && !que.empty(); j ++) {
Name[ans ++] = que.top().name;
que.pop();
}
}
while(cnt <= k) {
que.push(fs[cnt ++]);
}
while(!que.empty()) {
Name[ans ++] = que.top().name;
que.pop();
}
int x;
for(int i = 0; i < q; i ++) {
scanf("%d", &x);
if(i != 0) printf(" ");
cout << Name[x];
}
printf("\n");
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: