您的位置:首页 > 编程语言

POJ 1035 代码+具体的目光

2015-08-26 10:32 155 查看
Spell checker

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 19319 Accepted: 7060

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.

If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:

?deleting of one letter from the word;

?replacing of one letter in the word with an arbitrary letter;

?inserting of one arbitrary letter into the word.

Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.

The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.

All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then
write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the
input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i

is

has

have

be

my

more

contest

me

too

if

award

#

me

aware

m

contest

hav

oo

or

i

fi

mre

#

Sample Output

me is correct

aware: award

m: i my me

contest is correct

hav: has have

oo: too

or:

i is correct

fi: i

mre: more me

Source

Northeastern Europe 1998

<span style="color:#000099;">/******************************************
author    : Grant Yuan
time      : 2014/10/3 0:38
algorithm : 暴力
source    : POJ 1035
*******************************************/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<queue>
#include<string>

using namespace std;
const int MAX=10007;
struct word
{
char str[15];
int len;
};

word s[MAX];
int n;
queue<int> ans;
inline bool slove1(word s1,word s2)//推断两个字符串是否相等
{
if(strcmp(s1.str,s2.str)==0) return 1;
return 0;
}
inline bool slove2(word s1,word s2)//推断能否够由一个字符串添加或者降低一个字符得到还有一个字符串
{
int l1=s1.len,l2=s2.len;
int i,j;
bool ans=1;
for(i=0;i<l1&&i<l2;i++)
{
if(s1.str[i]!=s2.str[i]) ans=0;
}
if(ans) return 1;
for(i=0,j=0;i<l1&&j<l2;)
{
if(s1.str[i]==s2.str[j]){ i++;j++;}
else i++;
}
if(i==l1&&j==l2) return 1;
return 0;
}
inline bool slove3(word s1,word s2)//是否两个字符串仅仅有一个字符不想等
{
int ans=0;
int l=s1.len;
for(int i=0;i<l;i++)
{
if(s1.str[i]!=s2.str[i]) ans++;
}
if(ans==1) return 1;
return 0;
}
int main()
{
while(!ans.empty()) ans.pop();
word s1;
int n=0;
while(scanf(" %s",s1.str)!=EOF){
if(strcmp(s1.str,"#")==0) break;
strcpy(s[++n].str,s1.str);
s
.len=strlen(s1.str);
}
while(scanf(" %s",s1.str)!=EOF){
while(!ans.empty()) ans.pop();
if(strcmp(s1.str,"#")==0) break;
bool flag=1;
s1.len=strlen(s1.str);
for(int i=1;i<=n;i++)
{
int l2=s[i].len,l1=s1.len;
bool ans1=0;
if(l1==l2){
if(slove1(s1,s[i])) ans1=1;
}
if(ans1){flag=0;printf("%s is correct\n",s1.str);break;}
if(l1==l2){
if(slove3(s1,s[i])) ans.push(i);
}
if(l1-l2==1){
if(slove2(s1,s[i])) ans.push(i);
}
if(l2-l1==1){
if(slove2(s[i],s1)) ans.push(i);
}
}
if(flag){
printf("%s:",s1.str);
while(!ans.empty()){printf(" %s",s[ans.front()].str);ans.pop();}
printf("\n");
}
}
return 0;
}
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: