您的位置:首页 > 编程语言 > Java开发

ZOJ 3714 Java Beans

2015-08-24 14:03 447 查看
Java Beans

Time Limit: 2000MSMemory Limit: 65536KB64bit IO Format: %lld & %llu
Submit Status

Description

There are N little kids sitting in a circle, each of them are carrying some java beans in their hand. Their teacher want to select M kids who seated in M consecutive
seats and collect java beans from them.

The teacher knows the number of java beans each kids has, now she wants to know the maximum number of java beans she can get from M consecutively seated kids. Can you help her?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases.

For each test case, the first line contains two integers N (1 ≤ N ≤ 200) and M (1 ≤ M ≤ N).
Here N and M are defined in above description. The second line of each test case contains N integers Ci (1
≤ Ci ≤ 1000) indicating number of java beans the ith kid have.

Output

For each test case, output the corresponding maximum java beans the teacher can collect.

Sample Input

2
5 2
7 3 1 3 9
6 6
13 28 12 10 20 75


Sample Output

16
158


排序问题
例1:找5 个数中连在一起的2个数最大
例2:找6 个数中连在一起的6个数最大

本题要用到一个环形查找 如21行所示

#include<stdio.h>
int main (void)
{
int l[1500],T,a,i,b;
int sum,max,j;
scanf("%d",&T);
while(T--)
{
sum=0;
scanf("%d%d",&a,&b);
for(i=0;i<a;i++)
{
scanf("%d",&l[i]);
}
max=0;
for(i=0;i<a;i++)
{
sum=0;
for(j=0;j<b;j++)
{
sum+=l[(i+j)%a];
}
if(sum>=max) max=sum;
}
printf("%d\n",max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: