您的位置:首页 > 理论基础 > 计算机网络

Oulipo(http://acm.hdu.edu.cn/showproblem.php?pid=1686)

2015-08-24 10:33 621 查看


Oulipo

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7715 Accepted Submission(s): 3101



Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN


Sample Output

1
3
0


Source

华东区大学生程序设计邀请赛_热身赛
#include<cstdio>
#include<cstring>
#define max 10010
int p[max];
char s2[max*100];
char s1[max];
int l1,l2,num;
void getp()//得到p数组,即s1下标的值;
{
int i=0,j=-1;//初始
p[0]=-1;
while(i<l1)
{
if(j==-1||s1[i]==s1[j])
{
i++;
j++;
p[i]=j;
}
else
j=p[j];
}
}
void kmp()
{
getp();
int i=0,j=0;
p[0]=-1;
while(i<l2)
{
if(j==-1||s1[j]==s2[i])
{
i++;
j++;
if(j==l1)
{
num++;
j=p[j];//标记
}
}
else
j=p[j];
//		if(j==l1)//这个也是对的。
//		{
//			num++;
//			j=p[j];
//		}
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%s",s1);
scanf("%s",s2);
l1=strlen(s1);
l2=strlen(s2);
num=0;
kmp();
printf("%d\n",num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: