您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表四:有序链表的归并

2015-08-11 14:25 204 查看

数据结构实验之链表四:有序链表的归并

题目描述

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

输入

第一行输入M与N的值;

第二行依次输入M个有序的整数;

第三行依次输入N个有序的整数。

输出

输出合并后的单链表所包含的M+N个有序的整数。

示例输入

6 5
1 23 26 45 66 99
14 21 28 50 100


示例输出

1 14 21 23 26 28 45 50 66 99 100


#include <iostream>

#include<cstdio>

#include<cstdlib>

using namespace std;

struct node

{

int data;

struct node *next;

}*head,*tail,*p,*q;

struct node *merge(struct node *head1,struct node *head2)

{

struct node *p1,*p2;

p1=head1->next;

p2=head2->next;

tail=head1;

free(head2);

while(p1&&p2)

{

if(p1->data<p2->data)

{

tail->next=p1;

tail=p1;

p1=p1->next;

}

else

{

tail->next=p2;

tail=p2;

p2=p2->next;

}

if(p1)

{

tail->next=p1;

}

else

{

tail->next=p2;

}

}

return (head1);

}

struct node *creat(int n)

{

int i;

head=(struct node *)malloc(sizeof(struct node));

head->next=NULL;

tail=head;

for(i=0; i<n; i++)

{

p=(struct node *)malloc(sizeof(struct node));

cin>>p->data;

p->next=NULL;

tail->next=p;

tail=p;

}

return (head);

}

void display(struct node *head)

{

p=head->next;

while(p)

{

if(p->next==NULL)

{

cout<<p->data;

}

else

{

cout<<p->data<<" ";

}

p=p->next;

}

}

int main()

{

struct node *head1,*head2;

int n,m;

cin>>n>>m;

head1=creat(n);

head2=creat(m);

head=merge(head1,head2);

display(head);

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: