您的位置:首页 > 编程语言 > Go语言

hd3635 Dragon Balls(之前题意翻译有误,已改正)

2015-08-04 00:04 477 查看

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4389 Accepted Submission(s): 1675



[align=left]Problem Description[/align]
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.



His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical
strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.

Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the
ball has been transported so far.

[align=left]Input[/align]
The first line of the input is a single positive integer T(0 < T <= 100).

For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).

Each of the following Q lines contains either a fact or a question as the follow format:

T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.

Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

[align=left]Output[/align]
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

[align=left]Sample Input[/align]

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1


[align=left]Sample Output[/align]

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2


恩,题目大意就是说,龙珠嘛,一开始一个城市一个,然后给你有两个指令,T a b,就是把第a个龙珠所在城市的所有龙珠转移到第b个龙珠所在城市,Q a问的事第a个龙珠目前所在城市,以及该城市所有的龙珠个数,以及该龙珠被转移的次数。这里龙珠目前所在城市以及城市的所有龙珠个数都不难求,有点绕的是龙珠的转移次数,子节点的要加上父节点的,个人理解,父节点转移时子节点也跟着转移,不管父节点与子节点转移时间的前后。

#include<cstdio>
#include<cstring>
#define maxn 10000+10
int per[maxn];
int rec[maxn];//记录城市所有的龙珠个数
int ran[maxn];//记录转移次数

int find(int x)
{
if(x!=per[x])
{
int t=per[x];
per[x]=find(per[x]);
ran[x]+=ran[t];//这里加上父节点的次数
}
return per[x];
}
int join(int a,int b)
{
int fa=find(a);
int fb=find(b);
if(fa!=fb)
{
per[fa]=fb;
rec[fb]+=rec[fa];//这里把子节点的龙珠全给父节点
ran[fa]++;//转移次数加1
}
}
int main()
{
int T,n,m,a,b,cnt=0;
char c;
scanf("%d",&T);
while(T--)
{
cnt++;
scanf("%d %d",&n,&m);
for(int i=1;i<=n;++i)
{
per[i]=i;
rec[i]=1;
ran[i]=0;
}
printf("Case %d:\n",cnt);
while(m--)
{
getchar();
scanf("%c %d",&c,&a);
if(c=='T')
{
scanf("%d",&b);
join(a,b);
}
else if(c=='Q')
{
int t=find(a);//这里若不替换一下的话,到下面输出时会有变化
printf("%d %d %d\n",t,rec[t],ran[a]);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: