您的位置:首页 > 编程语言 > C语言/C++

n a^o7 !

2015-07-30 19:36 471 查看

n a^o7 !


Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

 

All brave and intelligent fighters, next you will step into a distinctive battleground which is full of sweet and happiness. If you want to win the battle, you must do warm-up according to my instructions, which can make you in the best state
preparing to fight. Now please relax yourself and enjoy the good moment. Before you raise your sharp sword to the enemy who guards the battleground, please allow me to tell you a true and romantic story about a samurai like you. 

Samurai hh fell in love with girl ss, who is charming and demure. He realized the truth that he must spend his remaining life with ss, and resolved to pursue the hard-won affection. One day hh wrote a letter to ss, when she opens the letter with excitement
her mind was in tangle. She found herself completely not to figure out the meaning about the letter, which said that "n 55!w ! pue n a^o7 ! n paau !". ss also immersed herself in guessing the meaning of that letter for a long time because of her adore to hh.
Finally she called hh to ask the meaning of the letter. On the other side of the phone, hh was too nervous to say. Gradually he calmed down himself and told ss to reverse the letter and read it. Then on both ends of the phone comes the voice at the same time
"i need u i love u and i miss u".

ss wants to tell each of you however you are Brave And Skilled, you shouldn't forget to express your loyal love and romantic feelings to your prince or princess.

Now the horn sounds for battle,do it by the following input and output. I think each of you will get an "Accepted" in this battle with pleasant mood.
 

输入

Input contains an integer T in the first line, and then T lines follow .Each line contains a message (only contain 'n5!wpuea^o7!' and 

' '(space)), the message's length is no more than 100.

输出

Output the case number and the message. (As shown in the sample output)

示例输入

2n 55!w ! pue n a^o7 ! n paau !n5!wpuea^o7


示例输出

Case 1: i need u i love u and i miss uCase 2: loveandmisu


千万不要被这一大串英文给迷惑了,这里面有用的就只有一句  :(only contain 'n5!wpuea^o7!' and 

' '(space)),这就是一个简单的字符串处理问题,把字符串倒过来看就可以了

#include<stdio.h>
#include<string.h>
int main()
{
char str[210];
int T,i,j,n;
scanf("%d",&T);
for(i=1;i<=T;i++)
{
if(i==1)
getchar();
gets(str);
n=strlen(str);
for(j=0;j<n;j++)
{
if(str[j]=='n')
str[j]='u';
else if(str[j]=='5')
str[j]='s';
else if(str[j]=='!')
str[j]='i';
else if(str[j]=='w')
str[j]='m';
else if(str[j]=='p')
str[j]='d';
else if(str[j]=='u')
str[j]='n';
else if(str[j]=='e')
str[j]='a';
else if(str[j]=='a')
str[j]='e';
else if(str[j]=='^')
str[j]='v';
else if(str[j]=='7')
str[j]='l';
}
printf("Case %d: ",i);
for(j=n-1;j>=0;j--)
{
printf("%c",str[j]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c语言 字符串