您的位置:首页 > 其它

POJ 2482 Stars in Your Window(扫描线)

2015-07-21 10:25 357 查看
Description

Fleeting time does not blur my memory of you. Can it really be 4 years since I first saw you? I still remember, vividly, on the beautiful Zhuhai Campus, 4 years ago, from the moment I saw you smile, as you were walking out of the classroom and turned your head
back, with the soft sunset glow shining on your rosy cheek, I knew, I knew that I was already drunk on you. Then, after several months’ observation and prying, your grace and your wisdom, your attitude to life and your aspiration for future were all strongly
impressed on my memory. You were the glamorous and sunny girl whom I always dream of to share the rest of my life with. Alas, actually you were far beyond my wildest dreams and I had no idea about how to bridge that gulf between you and me. So I schemed nothing
but to wait, to wait for an appropriate opportunity. Till now — the arrival of graduation, I realize I am such an idiot that one should create the opportunity and seize it instead of just waiting.

These days, having parted with friends, roommates and classmates one after another, I still cannot believe the fact that after waving hands, these familiar faces will soon vanish from our life and become no more than a memory. I will move out from school tomorrow.
And you are planning to fly far far away, to pursue your future and fulfill your dreams. Perhaps we will not meet each other any more if without fate and luck. So tonight, I was wandering around your dormitory building hoping to meet you there by chance. But
contradictorily, your appearance must quicken my heartbeat and my clumsy tongue might be not able to belch out a word. I cannot remember how many times I have passed your dormitory building both in Zhuhai and Guangzhou, and each time aspired to see you appear
in the balcony or your silhouette that cast on the window. I cannot remember how many times this idea comes to my mind: call her out to have dinner or at least a conversation. But each time, thinking of your excellence and my commonness, the predominance of
timidity over courage drove me leave silently.

Graduation, means the end of life in university, the end of these glorious, romantic years. Your lovely smile which is my original incentive to work hard and this unrequited love will be both sealed as a memory in the deep of my heart and my mind. Graduation,
also means a start of new life, a footprint on the way to bright prospect. I truly hope you will be happy everyday abroad and everything goes well. Meanwhile, I will try to get out from puerility and become more sophisticated. To pursue my own love and happiness
here in reality will be my ideal I never desert.

Farewell, my princess!

If someday, somewhere, we have a chance to gather, even as gray-haired man and woman, at that time, I hope we can be good friends to share this memory proudly to relight the youthful and joyful emotions. If this chance never comes, I wish I were the stars in
the sky and twinkling in your window, to bless you far away, as friends, to accompany you every night, sharing the sweet dreams or going through the nightmares together.



Here comes the problem: Assume the sky is a flat plane. All the stars lie on it with a location (x, y). for each star, there is a grade ranging from 1 to 100, representing its brightness, where 100 is the brightest and 1 is the weakest. The window is a rectangle
whose edges are parallel to the x-axis or y-axis. Your task is to tell where I should put the window in order to maximize the sum of the brightness of the stars within the window. Note, the stars which are right on the edge of the window does not count. The
window can be translated but rotation is not allowed.

Input

There are several test cases in the input. The first line of each case contains 3 integers: n, W, H, indicating the number of stars, the horizontal length and the vertical height of the rectangle-shaped window. Then n lines follow, with 3 integers each: x,
y, c, telling the location (x, y) and the brightness of each star. No two stars are on the same point.

There are at least 1 and at most 10000 stars in the sky. 1<=W,H<=1000000, 0<=x,y<2^31.

Output

For each test case, output the maximum brightness in a single line.

Sample Input

3 5 4
1 2 3
2 3 2
6 3 1
3 5 4
1 2 3
2 3 2
5 3 1


Sample Output

5
6


题意:就是给你一个W*H的窗口,问你窗口内能包含的最大星星的亮度是多少
分析:首先我们要建立一个概念就是一个星星(x,y)所能影响的范围是(x,y)->(x+W-1,y+H-1)(窗口边缘不算)
那么将Y的坐标离散化,每个点存能够被影响到的最大值。扫一遍即可。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string>
#include<iostream>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
#include<set>
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
typedef long long LL;
const int maxn=1e5+100;
int n,W,H;
struct node{
    int l,r;
    LL add,sum;//lazy&&最大值
}t[maxn<<2];
LL b[maxn<<2];
struct Line{
    LL x,y1,y2;
    LL val;
}line[maxn<<2];
int cmp(Line l1,Line l2)
{
    if(l1.x==l2.x)
        return l1.val>l2.val;
    return l1.x<l2.x;
}
void pushdown(int rs)
{
    if(t[rs].add)
    {
        t[rs<<1].add+=t[rs].add;
        t[rs<<1].sum+=t[rs].add;

        t[rs<<1|1].add+=t[rs].add;
        t[rs<<1|1].sum+=t[rs].add;
        t[rs].add=0;
    }
}
void pushup(int rs)
{
    t[rs].sum=max(t[rs<<1].sum,t[rs<<1|1].sum);
}
void build(int rs,int l,int r)
{
    t[rs].l=l;
    t[rs].r=r;
    t[rs].add=t[rs].sum=0;
    if(l==r)
        return ;
    int mid=(l+r)>>1;
    build(rs<<1,l,mid);
    build(rs<<1|1,mid+1,r);
}

void update(int rs,Line e)
{
    if(b[t[rs].l]==e.y1&&b[t[rs].r]==e.y2)
    {
        t[rs].add+=e.val;
        t[rs].sum+=e.val;
        return;
    }
    pushdown(rs);
    int mid=(t[rs].l+t[rs].r)>>1;
    if(e.y2<=b[mid])
        update(rs<<1,e);
    else if(e.y1>b[mid])
        update(rs<<1|1,e);
    else
    {
        Line e1=e;
        e1.y2=b[t[rs<<1].r];
        update(rs<<1,e1);
        Line e2=e;
        e2.y1=b[t[rs<<1|1].l];
        update(rs<<1|1,e2);
    }
    pushup(rs);
}
int main()
{
    LL x,y,c;
    while(~scanf("%d%d%d",&n,&W,&H))
    {
        int tot=1;
        for(int i=0;i<n;i++)
        {
            scanf("%lld%lld%lld",&x,&y,&c);
            line[tot].x=x;line[tot].y1=y;line[tot].val=c;
            line[tot].y2=y+H-1;b[tot++]=y;
            line[tot].x=x+W-1;line[tot].y1=y;line[tot].val=-c;
            line[tot].y2=y+H-1;b[tot++]=y+H-1;
        }
        sort(line+1,line+tot,cmp);
        sort(b+1,b+tot);
        int len=unique(b+1,b+tot)-(b+1);
        build(1,1,len);
        LL ans=-INF;
        for(int i=1;i<tot;i++)
        {
            update(1,line[i]);
            ans=max(ans,t[1].sum);
        }
        printf("%lld\n",ans);
    }
    return 0;
}
//all rights
/*
3 5 4
1 2 3
2 3 2
6 3 1

3 5 4
1 2 3
2 3 2
5 3 1

1 1 1
1 1 1
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: