您的位置:首页 > 其它

POJ 2586:Y2K Accounting Bug

2015-07-09 19:44 363 查看
Y2K Accounting Bug

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 11297Accepted: 5686
Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.

All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how
many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost
sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
Input

Input is a sequence of lines, each containing two positive integers s and d.
Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
Sample Input
59 237
375 743
200000 849694
2500000 8000000

Sample Output
116
28
300612
Deficit


题意是这个公司只有5个月的财务报表,因为一年有12个月,所以这样的财务报表有8个,这8个财务报表都是亏损,这个公司自己也不记得哪个月盈余哪个月亏损,只给出盈余多少,亏损多少。求该公司一年的最好盈余情况,如果不可能盈余,就输出Deficit。

我自己是不知道为什么这道题被归到了贪心里面,就是四种情况取最大值呗。

SSSSDSSSSDSS

SSSDDSSSDDSS

SSDDDSSDDDSS

SDDDDSDDDDSD

之前反倒吃了贪心的亏,忘记了要输出最好情况结果还来了两个WA。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;

int main()
{
	int s,d;
	while(cin>>s>>d)
	{
		int result=-1;
		if(4*s<d)
		{
			if(10*s-2*d>result)
				result=10*s-2*d;
		}
		if(3*s<2*d)
		{
			if(8*s-4*d>result)
				result=8*s-4*d;
		}
		if(2*s<3*d)
		{
			if(6*s-6*d>=0)
				result= 6*s-6*d;
		}
		if(s<4*d)
		{
			if(3*s-9*d>result)
				result=3*s-9*d;
		}
		if(result<0)
		{
			cout<<"Deficit"<<endl;
		}
		else
		{
			cout<<result<<endl;
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: