您的位置:首页 > 编程语言 > C语言/C++

第十五周oj刷题——Problem D: C++习题 对象数组输入与输出

2015-06-21 12:08 453 查看
Description

建立一个对象数组,内放n(n<10)个学生的数据(学号、成绩),用指针指向数组首元素,输出第奇数(1,3,5,7)个学生的数据。

Input

n和n个学生的学号、成绩

Output

奇数学生的数据

Sample Input

5

101 78.5

102 85.5

103 98.5

104 100.0

105 95.5

Sample Output

101 78.50

103 98.50

105 95.50

/* All rights reserved.
* 文件名称:test.cpp
* 作者:陈丹妮
* 完成日期:2015年 6 月 21 日
* 版 本 号:v1.0
*/
#include <iostream>
#include <iomanip>
using namespace std;
class Student
{
private:
int n;
double s;
public:
void input();
void display();
};
void Student::input()
{
cin>>n>>s;
}
void Student::display()
{
cout<<n<<" "<<s<<endl;
}
int main()
{
const int NUM=10;
Student stud[NUM];
int n,i;
cin>>n;
for(i=0; i<n; i++)
stud[i].input();
cout<<setiosflags(ios::fixed);
cout<<setprecision(2);
Student *p=stud;
for(i=0; i<n; p+=2,i+=2)
p->display();
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: