您的位置:首页 > 编程语言 > Go语言

POJ2262 Goldbach's Conjecture(素数问题)

2015-05-31 22:48 645 查看

Goldbach's Conjecture

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 40445Accepted: 15481
Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:

Every even number greater than 4 can be

written as the sum of two odd prime numbers.

For example:

8 = 3 + 5. Both 3 and 5 are odd prime numbers.

20 = 3 + 17 = 7 + 13.

42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)

Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

Input

The input will contain one or more test cases.

Each test case consists of one even integer n with 6 <= n < 1000000.

Input will be terminated by a value of 0 for n.
Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair
where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."
Sample Input
8
20
42
0


Sample Output
8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

题目大意:

给定一个数,问这个数是否能写成两个素数之和,如果可以输出两个素数差值最大的那一对。

解题思路:

100W的数据量筛法一直超时,所以可以把不需要的枝叶剪掉,比如输入的值肯定为偶数,因为奇数 = 偶数 + 奇数,所以不满足条件,当输入的值为偶数时,偶数 = 偶数 + 偶数显然不满足条件,筛掉,再者偶数 = 质数 + 合数 | 合数 + 合数也不行筛掉,效率可以提高非常多。

AC代码:

<span style="font-size:14px;">#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;

const int maxn = 1000001;
const int inf = 0xfffffff;
bool vis[maxn];
int a[maxn];
int cnt;

bool judge_prime(int num)
{
int i;
bool flag = true;
if(num % 2 == 0) //如果num不是质数
return false;
else
{
for(i=3;i*i<=num;i+=2) //如果num有因子,那么最多也为sqrt(num)而已
{
if(num % i == 0) //如果它不是质数,有因子
{
flag = 0;
break;
}
}
if(flag)
return true;
}
return false;
}

int main()
{
int m;
while(cin>>m && m)
{
int maxm = -inf;
int num;
int pos1,pos2;
bool flag = false;
int i,j;
if(m % 2 || m < 6)  //如果是合数或者小于6不满足条件
{
cout<<"Goldbach's conjecture is wrong."<<endl;
return 0;
}
for(i=3;i<=m/2;i+=2) //奇数
{
if(judge_prime(i) && judge_prime(m-i))
{
cout<<m<<" = "<<i<<" + "<<m-i<<endl;
flag = true;
break;
}
}
if(flag == false)
{
cout<<"Goldbach's conjecture is wrong."<<endl;
}
}
return 0;
} </span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: