您的位置:首页 > 理论基础 > 计算机网络

A simple Gaussian elimination problem.(hdu4975)网络流+最大流

2015-03-23 11:29 232 查看

A simple Gaussian elimination problem.

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 728 Accepted Submission(s):
241


Problem Description
Dragon is studying math. One day, he drew a table with
several rows and columns, randomly wrote numbers on each elements of the table.
Then he counted the sum of each row and column. Since he thought the map will be
useless after he got the sums, he destroyed the table after that.

However
Dragon's mom came back and found what he had done. She would give dragon a feast
if Dragon could reconstruct the table, otherwise keep Dragon hungry. Dragon is
so young and so simple so that the original numbers in the table are one-digit
number (e.g. 0-9).

Could you help Dragon to do that?



Input
The first line of input contains only one integer,
T(<=30), the number of test cases. Following T blocks, each block describes
one test case.

There are three lines for each block. The first line
contains two integers N(<=500) and M(<=500), showing the number of rows
and columns.

The second line contains N integer show the sum of each
row.

The third line contains M integer show the sum of each column.



Output
Each output should occupy one line. Each line should
start with "Case #i: ", with i implying the case number. For each case, if we
cannot get the original table, just output: "So naive!", else if we can
reconstruct the table by more than one ways, you should output one line contains
only: "So young!", otherwise (only one way to reconstruct the table) you should
output: "So simple!".



Sample Input
3
1 1

5

5
2 2

0 10
0 10
2 2

2 2
2 2




Sample Output
Case #1: So simple!
Case #2: So naive!
Case #3: So young!


网络流+最大流
题意:输入N*M的表格,在里面输入0-9内的数字,是的每行每列相加等于对应的值,如果表格唯一就输出Case #%d: So simple!;如果表格不唯一,则输出Case #%d: So young!;如果表格不存在,就输出Case #%d: So naive!


题目和hdu4888类似;






#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
#include <numeric>
using namespace std;
typedef long long LL;
const int MAXN = 510;
const int MAXV = MAXN << 1;
const int MAXE = 2 * MAXN * MAXN;
const int INF = 0x3f3f3f3f;
struct ISAP
{
    int head[MAXV], cur[MAXV], gap[MAXV], dis[MAXV], pre[MAXV];
    int to[MAXE], next[MAXE], flow[MAXE];
    int n, ecnt, st, ed;
    void init(int n)
    {
        this->n = n;
        memset(head + 1, -1, n * sizeof(int));
        ecnt = 0;
    }
    void add_edge(int u, int v, int c)
    {
        to[ecnt] = v;
        flow[ecnt] = c;
        next[ecnt] = head[u];
        head[u] = ecnt++;
        to[ecnt] = u;
        flow[ecnt] = 0;
        next[ecnt] = head[v];
        head[v] = ecnt++;

    }
    void bfs()
    {
        memset(dis + 1, 0x3f, n * sizeof(int));
        queue<int> que;
        que.push(ed);
        dis[ed] = 0;
        while(!que.empty())
        {
            int u = que.front();
            que.pop();
            gap[dis[u]]++;
            for(int p = head[u]; ~p; p = next[p])
            {
                int v = to[p];
                if(flow[p ^ 1] && dis[u] + 1 < dis[v])
                {
                    dis[v] = dis[u] + 1;
                    que.push(v);
                }
            }
        }
    }  int max_flow(int ss, int tt)
    {
        st = ss, ed = tt;
        int ans = 0, minFlow = INF;
        for(int i = 0; i <= n; ++i)
        {
            cur[i] = head[i];
            gap[i] = 0;

        }
        bfs();
        int u = pre[st] = st;
        while(dis[st] < n)
        {
            bool flag = false;
            for(int &p = cur[u]; ~p; p = next[p])
            {
                int v = to[p];
                if(flow[p] && dis[u] == dis[v] + 1)
                {
                    flag = true;
                    minFlow = min(minFlow, flow[p]);
                    pre[v] = u;
                    u = v;
                    if(u == ed)
                    {
                        ans += minFlow;
                        while(u != st)
                        {
                            u = pre[u];
                            flow[cur[u]] -= minFlow;
                            flow[cur[u] ^ 1] += minFlow;

                        }
                        minFlow = INF;

                    }
                    break;

                }

            }
            if(flag) continue;
            int minDis = n - 1;
            for(int p = head[u]; ~p; p = next[p])
            {
                int &v = to[p];
                if(flow[p] && dis[v] < minDis)
                {
                    minDis = dis[v];
                    cur[u] = p;

                }
            }
            if(--gap[dis[u]] == 0) break;
            ++gap[dis[u] = minDis + 1];
            u = pre[u];

        }
        return ans;

    } int stk[MAXV], top;
    bool sccno[MAXV], vis[MAXV];
    bool dfs(int u, int f, bool flag)
    {
        vis[u] = true;
        stk[top++] = u;
        for(int p = head[u]; ~p; p = next[p]) if(flow[p])
            {
                int v = to[p];
                if(v == f) continue;
                if(!vis[v])
                {
                    if(dfs(v, u, flow[p ^ 1])) return true;

                }
                else if(!sccno[v]) return true;

            }
        if(!flag)
        {
            while(true)
            {
                int x = stk[--top];
                sccno[x] = true;
                if(x == u) break;

            }

        }
        return false;

    }
    bool acycle()
    {
        memset(sccno + 1, 0, n * sizeof(bool));
        memset(vis + 1, 0, n * sizeof(bool));
        top = 0;
        return dfs(ed, 0, 0);

    }
} G;
int row[MAXN], col[MAXN];
int mat[MAXN][MAXN];
int n, m, k, ss, tt;
void solve()
{
    int sumr = accumulate(row + 1, row + n + 1, 0);
    int sumc = accumulate(col + 1, col + m + 1, 0);
    if(sumr != sumc)
    {
        puts("So naive!");
        return ;

    }
    int res = G.max_flow(ss, tt);
    if(res != sumc)
    {
        puts("So naive!");
        return ;

    }
    if(G.acycle())
    {
        puts("So young!");

    }
    else
    {
        puts("So simple!");
    }

}
int main()
{
    int T,Case;
    scanf("%d",&T);

    for(Case=1;Case<=T;Case++)
    {
        scanf("%d%d",&n,&m);
        k=9;
        for(int i = 1; i <= n; ++i) scanf("%d", &row[i]);
        for(int i = 1; i <= m; ++i) scanf("%d", &col[i]);
        ss = n + m + 1, tt = n + m + 2;
        printf("Case #%d: ",Case);
        G.init(tt);
        for(int i = 1; i <= n; ++i) G.add_edge(ss, i, row[i]);
        for(int i = 1; i <= m; ++i) G.add_edge(n + i, tt, col[i]);
        for(int i = 1; i <= n; ++i)
        {
            for(int j = 1; j <= m; ++j)
            {
                mat[i][j] = G.ecnt ^ 1;
                G.add_edge(i, n + j, k);
            }
        }
        solve();

    }
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐