您的位置:首页 > 编程语言 > Java开发

hdu 1865 1sting (java大数&递推)

2014-12-15 21:24 411 查看

1sting

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3494 Accepted Submission(s): 1358



Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your
work is to find the total number of result you can get.



Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.



Output
The output contain n lines, each line output the number of result you can get .



Sample Input
3
1
11
11111




Sample Output
1
2
8
注意字符串的输入
import java.util.*;
import java.math.*;

public class Main
{
	public static void main(String args[])
	{
		Scanner cin=new Scanner(System.in);
		BigInteger[] F=new BigInteger[300];
		F[0]=F[1]=BigInteger.valueOf(1);
		for(int i=2;i<300;i++)
			F[i]=F[i-1].add(F[i-2]);
		String s;
		int n;
		n=cin.nextInt();
		while(n-->0)
		{
			s=cin.next();   //字符串的输入
			System.out.println(F[s.length()]);
		}
	}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: