您的位置:首页 > 其它

hdu 2120 Ice_cream's world I(判断是否有环,简单的并查集)

2014-11-11 23:46 357 查看

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 603 Accepted Submission(s): 347

Problem Description
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition
the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.


Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between
A and B has a wall(A and B are distinct). Terminate by end of file.


Output
Output the maximum number of ACMers who will be awarded.

One answer one line.


Sample Input
8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7




Sample Output
3




Author
Wiskey


Source
HDU 2007-10 Programming Contest_WarmUp

题意:
找到围成的环的个数。
代码如下:
#include<stdio.h>
int father[10010];
int find(int r)
{
	if(r!=father[r])
	return find(father[r]);
	else
	return father[r];
}
int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m))
	{
		int a,b,count=0;
		while(m--)
		{
			scanf("%d%d",&a,&b);
			int fa=find(a);
			int fb=find(b);
			if(fa==fb)
			count++;//判断是否有环,有的话,两者的父节点应该相等
			else
			father[fa]=fb;
		}
		printf("%d\n",count);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: