您的位置:首页 > 理论基础 > 数据结构算法

数据结构上机测试2-2:单链表操作B

2014-11-02 20:33 162 查看


Time Limit: 1000MS Memory limit: 65536K


题目描述

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。


输入

第一行输入元素个数n;

第二行输入n个整数。


输出

第一行输出初始链表元素个数;

第二行输出按照逆位序所建立的初始链表;

第三行输出删除重复元素后的单链表元素个数;

第四行输出删除重复元素后的单链表。


示例输入

10
21 30 14 55 32 63 11 30 55 30



示例输出

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21


#include<stdio.h>
#include<stdlib.h>
struct node
{
int data;
struct node *next;
};
struct node *creat(int n)
{
struct node *head,*p;
int i;
head=(struct node*)malloc(sizeof(struct node));
head->next=NULL;
for(i=1;i<=n;i++)
{
p=(struct node *)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=head->next;
head->next=p;
}
return head;
}
int del(struct node *head,int n)
{
struct node *p,*q,*t;
p=head->next;
while(p->next!=NULL)
{
q=p;
t=q->next;
while(t->next!=NULL)
{
if(t->data==p->data)
{
q->next=t->next;
free(t);
t=q->next;
n--;
}
else
{
q=t;
t=t->next;
}
}
if(t->next==NULL)
{
if(t->data==p->data)
{
q->next=NULL;
free(t);
n--;
}
}
p=p->next;
}
return n;
}
void show(struct node *head)
{
struct node *p;
p=head->next;
while(p!=NULL)
{
if(p->next!=NULL)
printf("%d ",p->data);
else printf("%d\n",p->data);
p=p->next;
}
}
int main()
{
struct node *head,*p;
int n,m;
scanf("%d",&n);
head=creat(n);
printf("%d\n",n);
show(head);
m=del(head,n);
printf("%d\n",m);
show(head);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: