您的位置:首页 > 理论基础 > 计算机网络

HDOJ 5012 Dice--2014网络赛西安赛区F题

2014-09-15 09:52 351 查看
题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=5012


Dice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 307    Accepted Submission(s): 183


Problem Description

There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a1.a2,a3,a4,a5,a6 to be numbers written on top face, bottom face, left face, right face,
front face and back face of dice A. Similarly, consider b1.b2,b3,b4,b5,b6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller
than 1 and no more than 6 while ai ≠ aj and bi ≠ bj for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, ai ≠ bi). Ddy wants to make the two dices look the same from all directions(which means for all i, ai = bi) only by the following
four rotation operations.(Please read the picture for more information)



Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.

 

Input

There are multiple test cases. Please process till EOF. 

For each case, the first line consists of six integers a1,a2,a3,a4,a5,a6, representing the numbers on dice A. 

The second line consists of six integers b1,b2,b3,b4,b5,b6, representing the numbers on dice B.

 

Output

For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.

 

Sample Input

1 2 3 4 5 6
1 2 3 4 5 6
1 2 3 4 5 6
1 2 5 6 4 3
1 2 3 4 5 6
1 4 2 5 3 6

 

Sample Output

0
3
-1

 

Source

2014 ACM/ICPC Asia Regional Xi'an Online

 

题意: 有两个色子,每次可以选择向前面、后面、左边或是右边翻转90度。给你色子的初始状态,输出使的两个筛子达到相同状态的最少次数,如果无法达到,则输出-1。

题解: BFS,网络赛处女A,两次TLE~~ 我用了hash判重AC,不知道需不需要用这个~~ 貌似状态不多,普通的方法应该也可以过吧!BFS部分,就是对四种情况进行遍历。

AC代码:
#include<cstdio>
#include<cmath>
#include<cstring>
#define Max 5000000
bool visit[2000000]={0};
struct Node{
int a[6],step;
}map[Max],temp,end;
int calc[6]={1,10,100,1000,10000,100000};
int hash(Node x)
{  	 int sum=0;
for(int i=0;i<6;i++){
sum+=x.a[i]*calc[i];
}
return sum;
}
int main(){   //六个面的编号  上0  下2  左3  右1  前4  后5
while(~scanf("%d%d%d%d%d%d",&map[0].a[0],&map[0].a[2],&map[0].a[3],&map[0].a[1],&map[0].a[4],&map[0].a[5])){
memset(visit,0,sizeof(visit));
scanf("%d%d%d%d%d%d",&end.a[0],&end.a[2],&end.a[3],&end.a[1],&end.a[4],&end.a[5]);
map[0].step=0; end.step=0;
visit[hash(end)]=1;
visit[hash(map[0])]=1;
int exdir=0,nodedir=0,flag=1;
if(hash(map[0])==hash(end)){   //完全一样,直接输出0
printf("%d\n",0);
continue;
}
while(nodedir<=exdir&&exdir<Max&&flag){
for(int i=0;i<4;i++){
temp=map[nodedir];
//向前翻转
if(!i){
int x,y;
x=temp.a[0]; temp.a[0]=temp.a[5];
y=temp.a[4]; temp.a[4]=x;
x=temp.a[2]; temp.a[2]=y;
temp.a[5]=x;
}
//向后翻转
else if(i==1){
int x=temp.a[5]; temp.a[5]=temp.a[0];
int y=temp.a[2]; temp.a[2]=x;
x=temp.a[4]; temp.a[4]=y;
temp.a[0]=x;
}
//向左翻转
else if(i==2){
int x=temp.a[3]; temp.a[3]=temp.a[0];
int y=temp.a[2]; temp.a[2]=x;
x=temp.a[1]; temp.a[1]=y;
temp.a[0]=x;
}
//向右翻转
else{
int x=temp.a[1]; temp.a[1]=temp.a[0];
int y=temp.a[2]; temp.a[2]=x;
x=temp.a[3]; temp.a[3]=y;
temp.a[0]=x;
}
temp.step++;
if(hash(temp)==hash(end)) {   //达到目标,直接输出
printf("%d\n",temp.step);
flag=0;
break;
}
if(!visit[hash(temp)]) {   //新节点加入队列
map[++exdir]=temp;
visit[hash(temp)]=1;
}
}
nodedir++;
}
if(flag) printf("-1\n");  //无法达到目标状态
}
return 0;
}


【转载请注明出处】

Author: MummyDing

出处:http://blog.csdn.net/mummyding/article/details/39288513
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: