您的位置:首页 > 编程语言 > C语言/C++

北大暑假训练计划—POJ1207 The 3n + 1 problem(C语言)

2014-07-25 21:23 316 查看
                                                     The 3n + 1 problem
Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm:

        1.    input n

  2.    print n

  3.    if n = 1 then STOP

  4.       if n is odd then   n <-- 3n+1

  5.       else   n <-- n/2

  6.    GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however,
for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output
for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10

100 200

201 210

900 1000

Sample Output

1 10 20

100 200 125

201 210 89

900 1000 174

//题目大意:找出i和j之间循环得到1的循环次数最多的那个数

//因为循环的次数太多,所以要先将所有结果列出来,否则会超时

#include<stdio.h>

int s[10010];

void xunhuan()

{  

 int i,sum,c;

 for(i=1;i<=10000;i++)

 {    

    c=i;

    sum=0;

    while(1)

          {

          if(c==1)

          {

          sum++;

          break;

          }

          else if(c%2!=0)

          {   

               sum++;

               c=c*3+1;

          }

          else if (c%2==0)

          {   

               sum++;

               c=c/2;

          }

          }

    s[i]=sum;

 }

}

int main()

{  

 xunhuan();

 int a,b,max,i,x1,x2;

 while(scanf("%d%d",&a,&b)!=EOF)//输入a,b时不是按照从小到大的顺序输入的,所以要先判断  a,b 的大小,否则会wrong answer

 {  

  max=0;

  if(a>=b)

  {

   x1=b;

   x2=a;

  }

  else if(a<b)

  {

   x1=a;

   x2=b;

  }

  for(i=x1;i<=x2;i++)

  {

   if(s[i]>max)

    max=s[i];

  }

  printf("%d %d %d\n",a,b,max);

 }

 return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: