您的位置:首页 > 产品设计 > UI/UE

Longest Ordered Subsequence(最长上升子序列)

2014-07-05 19:38 435 查看
Longest Ordered Subsequence

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 31696Accepted: 13858
http://poj.org/problem?id=2533
Description
A numeric sequence of ai is ordered ifa1 <a2 < ... <aN. Let the subsequence of the given numeric sequence (a1,a2,
...,aN) be any sequence (ai1,ai2, ...,aiK), where 1 <=i1 <i2 < ... <iK <=N.
For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8

Sample Output
4

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
#define MAX 1010
int a[MAX],b[MAX];
int main()
{
    int n,t,i,j,k;
	while(scanf("%d",&n)!=EOF)
	{   memset(a,0,sizeof(a));
	    memset(b,0,sizeof(b)); 
	   for(i=0;i<n;i++)
	   {
		scanf("%d",&a[i]);
	   }
	   b[0]=a[0];
	   k=1;
	   for(i=1;i<n;i++)
	   {  
		   for(j=0;j<k;j++)
		   { 
               if(a[i]<=b[j])
			   {   
				     b[j]=a[i];
	                 break;
			   } 
		   } 
		   if(j>=k)
		   {   
			   b[k]=a[i];
			   k++;
		   } 
	   }
	   printf("%d\n",k);
	} 
	return 0;
}


这是一道简单DP——最长递增子序列,还有很多可以改进的地方。

解题的核心是在于不要考虑其中的数,只要得到最长子序列的长度,所以用后面较小的数取代前面较大的数,不用考虑位置问题。

例如:1 7 3 5 9 4 8

->1

->1 7 //没有比7大的,所以把7放在最后,数组长度+1.

->1 3 // 因为1<7,所以不做处理,直接往后走,因为7>3,所以用3替换掉7.

->1 3 5 //同理,没有比5大的,所以把5放在最后,数组长度+1.

->1 3 5 9

->1 3 5 8

和题意有些差别,不过能AC,感觉和贪心有点像,两个之间选小的。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: