您的位置:首页 > 编程语言

[POJ][1016]Numbers That Count

2014-05-21 13:37 393 查看
Description

"Kronecker's Knumbers" is a little company that manufactures plastic digits for use in signs (theater marquees, gas station price displays, and so on). The owner and sole employee, Klyde Kronecker, keeps track of how many digits of each type he has used by
maintaining an inventory book. For instance, if he has just made a sign containing the telephone number "5553141", he'll write down the number "5553141" in one column of his book, and in the next column he'll list how many of each digit he used: two 1s, one
3, one 4, and three 5s. (Digits that don't get used don't appear in the inventory.) He writes the inventory in condensed form, like this: "21131435". 

The other day, Klyde filled an order for the number 31123314 and was amazed to discover that the inventory of this number is the same as the number---it has three 1s, one 2, three 3s, and one 4! He calls this an example of a "self-inventorying number", and
now he wants to find out which numbers are self-inventorying, or lead to a self-inventorying number through iterated application of the inventorying operation described below. You have been hired to help him in his investigations. 

Given any non-negative integer n, its inventory is another integer consisting of a concatenation of integers c1 d1 c2 d2 ... ck dk , where each ci and di is an unsigned integer, every ci is positive, the di satisfy 0<=d1<d2<...<dk<=9, and, for each digit d
that appears anywhere in n, d equals di for some i and d occurs exactly ci times in the decimal representation of n. For instance, to compute the inventory of 5553141 we set c1 = 2, d1 = 1, c2 = 1, d2 = 3, etc., giving 21131435. The number 1000000000000 has
inventory 12011 ("twelve 0s, one 1"). 

An integer n is called self-inventorying if n equals its inventory. It is called self-inventorying after j steps (j>=1) if j is the smallest number such that the value of the j-th iterative application of the inventory function is self-inventorying. For instance,
21221314 is self-inventorying after 2 steps, since the inventory of 21221314 is 31321314, the inventory of 31321314 is 31123314, and 31123314 is self-inventorying. 

Finally, n enters an inventory loop of length k (k>=2) if k is the smallest number such that for some integer j (j>=0), the value of the j-th iterative application of the inventory function is the same as the value of the (j + k)-th iterative application. For
instance, 314213241519 enters an inventory loop of length 2, since the inventory of 314213241519 is 412223241519 and the inventory of 412223241519 is 314213241519, the original number (we have j = 0 in this case). 

Write a program that will read a sequence of non-negative integers and, for each input value, state whether it is self-inventorying, self-inventorying after j steps, enters an inventory loop of length k, or has none of these properties after 15 iterative applications
of the inventory function.
Input

A sequence of non-negative integers, each having at most 80 digits, followed by the terminating value -1. There are no extra leading zeros.
Output

For each non-negative input value n, output the appropriate choice from among the following messages (where n is the input value, j is a positive integer, and k is a positive integer greater than 1): 

n is self-inventorying 

n is self-inventorying after j steps 

n enters an inventory loop of length k 

n can not be classified after 15 iterations
Sample Input
22
31123314
314213241519
21221314
111222234459
-1

Sample Output
22 is self-inventorying
31123314 is self-inventorying
314213241519 enters an inventory loop of length 2
21221314 is self-inventorying after 2 steps
111222234459 enters an inventory loop of length 2


这是一道水题,模拟就行,但是要小心陷阱,比如我之前用一个长度为16的数组存放字符出现的次数,然后把[次数+'0']的值当作出现的次数的字符,这个在次数<10的情况下是正确的,但是题目中给的数字最多有80个,也就是说肯定会有字符出现次数在9之上,所以这种方法肯定是错的,正确方法是用sprintf转换.

然后就是到底是inventory loop还是self-inventorying要分清楚,这个可以根据循环变量的值以及相等的字符串的下标差来判断.

下面是AC代码

#include <iostream>
#include <cstdio>
using namespace std;

string getNumber(string num)
{
int container[10]{0};
for (int i=0; i<num.length(); i++) {
container[num[i]-'0']++;
}
string str="";
char temp[81];
for (int i=0; i<10; i++) {
if (container[i] != 0) {
sprintf(temp,"%d%d",container[i],i);
str+=temp;
}
}
return str;
}

int main()
{
string str[16];
while (cin>>str[0] && str[0]!="-1") {
for (int i=1; i<=15; i++) {
str[i] = getNumber(str[i-1]);
int iter = 16;
for (int j=i-1; j>=0; j--) {
if (str[j] == str[i]) {
iter = i-j;
}
}
if (iter == 1) {
if (i==1) {
cout<<str[0]<<" is self-inventorying"<<endl;
} else {
cout<<str[0]<<" is self-inventorying after "<<i-1<<" steps"<<endl;
}
break;
} else if (iter <16) {
cout<<str[0]<<" enters an inventory loop of length "<<iter<<endl;
break;
} else if (i==15) {
cout<<str[0]<<" can not be classified after 15 iterations"<<endl;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 源代码 模拟