您的位置:首页 > 编程语言 > C语言/C++

【C++】1016. Phone Bills (25)

2014-03-21 22:55 211 查看

1016. Phone Bills (25)

时间限制
400 ms

内存限制
32000 kB

代码长度限制
16000 B

判题程序
Standard

作者
CHEN, Yue

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone.
Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record
are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour
clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning
and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80


啦啦
#include<iostream>
#include<vector>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;

int t[24],tt[24];
struct bill{
char a[21];
int mm;
int dd;
int hh;
int min;
bool line;
};

int money(int hh,int mm){
int sum=0;
sum=tt[hh]+mm*t[hh];
return sum;
}

int cmp(bill a,bill b){
if(strcmp(a.a,b.a )==0){
if(a.mm==b.mm){
if(a.dd==b.dd){
if(a.hh==b.hh){
return a.min<b.min;
}else
return a.hh<b.hh;
}else
return a.dd<b.dd;

}else
return a.mm<b.mm;
}else
return strcmp(a.a,b.a)<0;
}

int main(){
vector<bill> b;
vector<bill>::iterator it;

freopen("in.txt","r",stdin);
int i;
tt[0]=0;
for(i=0;i<24;i++){
scanf("%d",&t[i]);
if(i>0){
tt[i]=tt[i-1]+t[i-1]*60;
}
}
bill bb;
char cc,ccc[30];
int N;
cin>>N;
while(N--){
scanf("%s%d:%d:%d:%d %c%c%s",bb.a,&bb.mm,&bb.dd,&bb.hh,&bb.min,&cc,&cc,&ccc);

if(cc=='f'){
bb.line=false;
}else{
bb.line=true;
}
b.push_back(bb);
}
sort(b.begin(),b.end(),cmp);
char tempname[21]="";
int mm=-1;
int amt=0;
int fdd,fhh,fmm,rdd,rhh,rmm;
bool f1=false,f2=false,ff=true;
int m1,m2;
//先排序,在输出。
for(it=b.begin();it!=b.end();it++){
if(strcmp(tempname,(*it).a)!=0||(*it).mm!=mm){
strcpy(tempname,(*it).a);
mm=(*it).mm;
if(ff){
ff=false;
}else{
printf("Total amount: $%d.%d\n",amt/100,amt%100);
}
printf("%s %02d\n",tempname,mm);
amt=0;
}
if((*it).line==true){
f1=true;
fdd=(*it).dd;
fhh=(*it).hh;
fmm=(*it).min;
}else{
f2=true;
rdd=(*it).dd;
rhh=(*it).hh;
rmm=(*it).min;
}
if(f1==true&&f2==true){
f1=false;
f2=false;
m1=money(rhh,rmm);
m2=money(fhh,fmm);
printf("%02d:%02d:%02d %02d:%02d:%02d ",fdd,fhh,fmm,rdd,rhh,rmm);
while(rhh-fhh<0){
rhh+=24;
rdd--;
}
while(rmm-fmm<0){
rmm+=60;
rhh--;
}
int tsum=m1-m2+(tt[23]+t[2]*60)*(rdd-fdd);
amt+=tsum;
int summ=rmm-fmm+(rhh-fhh)*60+(rdd-fdd)*60*24;
printf("%d $%d.%d\n",summ,tsum/100,tsum%100);

}

}
printf("Total amount: $%d.%d\n",amt/100,amt%100);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: