您的位置:首页 > 编程语言 > C语言/C++

【c++】PAT (Advanced Level)1012. The Best Rank (25)*

2014-02-26 14:16 423 查看

1012. The Best Rank (25)

时间限制
400 ms

内存限制
32000 kB

代码长度限制
16000 B

判题程序
Standard

作者
CHEN, Yue

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing
on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a
student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output
1 C
1 M
1 E
1 A
3 A
N/A


1.只有一个测试点正确,其实应该考虑并列的情况吧,到时候看看别人的程序
#include <iostream>
#include <string>
#include <vector>
#include <iomanip>
#include <algorithm>
using namespace std;
//C7
struct grade{
string ID;
int Cpro;
int CproR;
int Math;
int MathR;
int Eng;
int EngR;
int Ave;
int AveR;
};

bool compare1(grade a,grade b){
if(a.Ave>b.Ave){
return true;
}else{
return false;
}
}

bool compare2(grade a,grade b){
if(a.Cpro>b.Cpro){
return true;
}else{
return false;
}
}

bool compare3(grade a,grade b){
if(a.Math>b.Math){
return true;
}else{
return false;
}
}

bool compare4(grade a,grade b){
if(a.Eng>b.Eng){
return true;
}else{
return false;
}
}

int main() {
int n,m;
cin>>n>>m;
vector<grade> demo;
vector<grade>::iterator iter;
while(n--){
grade gra;
cin>>gra.ID>>gra.Cpro>>gra.Math>>gra.Eng;
gra.Ave=gra.Cpro+gra.Math+gra.Eng;
demo.push_back(gra);
}
sort(demo.begin(),demo.end(),compare1);//ave排序
for(iter=demo.begin();iter!=demo.end();iter++){
(*iter).AveR=iter-demo.begin()+1;
}
//cout<<demo[0].AveR;
sort(demo.begin(),demo.end(),compare2);//排序
for(iter=demo.begin();iter!=demo.end();iter++){
(*iter).CproR=iter-demo.begin()+1;
}

sort(demo.begin(),demo.end(),compare3);//排序
for(iter=demo.begin();iter!=demo.end();iter++){
(*iter).MathR=iter-demo.begin()+1;
}

sort(demo.begin(),demo.end(),compare4);//排序
for(iter=demo.begin();iter!=demo.end();iter++){
(*iter).EngR=iter-demo.begin()+1;
}

while(m--){
int num;
string iddemo;
cin>>iddemo;
string outp="ACME";
bool flag=true;
for(iter=demo.begin();iter!=demo.end();iter++){
if((*iter).ID==iddemo){
flag=false;
int i=0,n=(*iter).AveR;
if((*iter).CproR<n){
i=1,n=(*iter).CproR;
}
if((*iter).MathR<n){
i=2,n=(*iter).MathR;
}
if((*iter).EngR<n){
i=3,n=(*iter).EngR;
}
cout<<n<<" "<<outp[i]<<endl;
}
}
if(flag){
cout<<"N/A";
}
}
//cout<<" aa";
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: