您的位置:首页 > 编程语言 > Java开发

EASY_PAT_1065 用Java的BigInteger类解决大数问题

2014-02-25 23:04 435 查看
用C++自己写大数的算法,写了好久,结果有的时候还是会报错,无奈,只好用Java现成的BigInteger了。

来看题目:


1065. A+B and C (64bit) (20)

时间限制

100 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

HOU, Qiming

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).
Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:
Case #1: false
Case #2: true
Case #3: false


import java.util.*;
import java.math.*;

public class Main {

void test() {
int M = 0;
Scanner reader = new Scanner(System.in);
M = reader.nextInt();
int index = 0;
while (index<M) {
BigInteger bigInt = reader.nextBigInteger();
BigInteger bigInt2 = reader.nextBigInteger();
BigInteger bigInt3 = reader.nextBigInteger();

System.out.print("Case #"+(index+1)+": ");
if (bigInt.add(bigInt2).compareTo(bigInt3) > 0) {
System.out.println("true");
} else {
System.out.println("false");
}
index ++;
}
}

public static void main(String[] args) {
Main main = new Main();
main.test();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  OJ PAT ZJU java