您的位置:首页 > 编程语言

The Suspects

2014-02-25 20:28 169 查看
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0


Sample Output

4
1
1

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<ctype.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<math.h>
#include<vector>
#include<deque>
#include<list>
using namespace std;
int father[30001]; //存储father index
int group[30001]; //存储当前  集合的人数
//查找i的最终father
int find_set(int i)
{
int temp = i;
while (temp != father[temp])
{
temp = father[temp];
}
father[i] = temp;
return temp;
}
//合并两个点
void join(int x, int y)
{
int i = find_set(x);
int j = find_set(y);
if (i != j)
{
father[i] = father[j];
group[j] += group[i]; //合并时,由于最终father保存当前集合人数
}
}
int main()
{
int n, m, k;
while (scanf("%d %d", &n, &m) != EOF&&(n!=0))
{
for (int i = 0; i <= 30001; i++)//初始化
{
father[i] = i;
group[i] = 1;
}
for (int i = 0; i < m; i++)
{
scanf("%d",&k);
int pre, cur; //前一个 和 当前
for (int j = 0; j < k; j++)
{
scanf("%d",&cur);
if (j) //第一个数不用管
join(pre,cur);
pre = cur;
}
}
printf("%d\n", group[find_set(0)]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  编程