您的位置:首页 > 编程语言 > C语言/C++

POJ 3278解题报告(C语言版)//Catch That Cow

2014-02-25 14:31 483 查看
广搜的简单运用

B - Catch That Cow

Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Submit Status

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include<stdio.h>
#include<string.h>
struct A
{
    int s;//位置
    int point;//步数
}queue[1000000];//可以将其看成一个数组
int sign[1000000];//标记是否走过,1为已走,0为未走
int bfs(int n,int k)
{
    int head=0,rear=0;
    struct A r;
    sign
=1;//农夫开始位置做标记
    queue[rear].s=n,queue[rear].point=0,rear++;//入队
    while(head<rear)
    {
        r=queue[head++];//出队
        if(r.s+1>=0&&r.s+1<=100000&&!sign[r.s+1])
        {
            queue[rear].point=r.point+1;
            queue[rear++].s=r.s+1;
            sign[r.s+1]=1;
            if(queue[rear-1].s==k)
            return queue[rear-1].point;
        }
        if(r.s-1>=0&&r.s-1<=100000&&!sign[r.s-1])
        {
            queue[rear].point=r.point+1;
            queue[rear++].s=r.s-1;
            sign[r.s-1]=1;
            if(queue[rear-1].s==k)
            return queue[rear-1].point;

        }
        if(r.s*2>=0&&r.s*2<=100000&&!sign[r.s*2])
        {

            queue[rear].point=r.point+1;
            queue[rear++].s=r.s*2;
            sign[r.s*2]=1;
            if(queue[rear-1].s==k)
            return queue[rear-1].point;
        }
    }
    return 0;
}

int main()
{
    int n,k;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(sign,0,sizeof(sign));
        printf("%d\n", bfs(n,k));
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: